turned on debug in config and got an error


  • Mitchell
    April 28, 2019 at 10:46 am

    Notice: Undefined index: s in /home/xxxxxx/public_html/wp-content/themes/DT9/framework/new_class/ppt_core.php on line 18

    Notice: Undefined index: s in /home/xxxxxx/public_html/wp-content/themes/DT9/framework/new_class/ppt_core.php on line 18

    Warning: Cannot modify header information – headers already sent by (output started at /home/xxxxxx/public_html/wp-content/themes/DT9/framework/new_class/ppt_core.php:18) in /home/arcades/public_html/wp-admin/includes/misc.php on line 1198

  • JamesD
    JamesD
    April 29, 2019 at 2:22 am

    Hello Mitchell,

    Those are only notices and relatively minor, so it shouldn’t break anything when not in debug mode. Even though minor, displayed errors (in general) bug me too, so I always end up checking and fixing them.

    If you want to fix it, then all you would need to do is replace line #18 if(strlen($_GET['s']) < 3 && is_numeric($_GET['s'])){ with if(isset($_GET['s']) && strlen($_GET['s']) < 3 && is_numeric($_GET['s'])){ and it should remove those messages.

    I’ve attached the pp_core.php file with the change (if it’s easier than a manual change).
    Note: the file is from v9.2.6.

    Attachments:
    You must be logged in to view attached files.

  • Mitchell
    April 29, 2019 at 2:54 am

    Thank You so Much
    Mitch

  • JamesD
    JamesD
    April 29, 2019 at 3:26 am

    You’re welcome Mitchell.

Viewing 4 posts - 1 through 4 (of 4 total)

Copyright © 2010-2020 PremiumPress Limited.

secure payments