Google Maps doesn't work on search results pages

WordPress Business Themes Forums Responsive Themes Directory Theme Google Maps doesn't work on search results pages

Google Maps doesn't work on search results pages

July 9, 2018
Michel Michel
  • JamesD
    JamesD
    Super Guru 917 points

    Hello Michel,

    I’m not seeing what you’re referring to on your site because it looks like the maps are being displayed, nor am I seeing any of the errors like you had before (which is good):

    July 22, 2018 at 7:42 pm
  • Michel
    Michel
    Newbie 18 points

    Hello James,
    I’m quite sure that the bug comes from the browser used. All is OK with Google Chrome.
    Problem exist only with Mozilla and Explorer !!
    Witch browser are you using ?

    July 23, 2018 at 6:55 am
  • JamesD
    JamesD
    Super Guru 917 points

    Hello Michel,

    Looks like a problem with invalid HTML. Could be a bug or caused from the one of the accents and/or characters within the listing titles.

    You can try this, however this alters a core file… Rename your current ‘/DT/framework/class/class_objects.php’ file to something else like ‘/DT/framework/class/class_objects.072318.bak’.

    Extract the attached file and upload it to your ‘/DT/framework/class/’ folder to replace the file you just renamed.

    The only change I made was around line #1472 where it starts with:
    str_replace($permalink,'javascript:void(0);"
    and I added an opening quote:
    str_replace($permalink,'"javascript:void(0);"

    See if that helps. If it doesn’t then delete the file and rename the original file back to ‘class_objects.php’ and then find what ever encoding problem it has.
    Note: You can hit the F12 key to open the debug window/console and see what errors the page has.

    Attachments:
    You must be logged in to view attached files.
    July 23, 2018 at 8:23 am
  • Michel
    Michel
    Newbie 18 points

    Hello James,
    I replaced file: class_objects.php with the class_objects.php you sent: On the home Page, with Mozilla , Google Map never appears (always a grey screen).
    Back: (your file has been renamed : class_objects-james.php) , refresh: Google Maps appears and desappears again after vsiting an other page and back to home….
    You said it’s probably due to an invalid HTML listing title: Can I check it by moving to draw all (except on or two) items of the listings ??
    Thanks a lot for your help James !!

    July 23, 2018 at 2:19 pm
  • JamesD
    JamesD
    Super Guru 917 points

    Hello Michel,

    What I can see at the moment is that the browser chokes on the line with the map location information.

    Within that information there’s data that’s not being properly backslashed and missing a single and/or double quote. Encoding from language accents/characters and symbols can cause the issue too.
    Note: Sometimes copy/pasting data from other software, i.e. Microsoft Word, can also add invisible characters that could cause this as well.

    You have quite a few listings, so I haven’t been able to determine which listing, or listings, that has the offending data.

    Can I check it by moving to draw all (except on or two) items of the listings ??

    If I’m understanding you correctly, yes. You can try to place potentially offending listings as ‘Draft’ and check.

    July 23, 2018 at 6:38 pm
  • JamesD
    JamesD
    Super Guru 917 points

    @ Michel,

    You may want to take a look at these listings first:

    Perigord - Domaine de La Rebière de 15 à 40 personnes
    Proche Paris: Family Ecolodge, hébergements insolites
    Ile dOléron - Village vacances - Les Heures Joyeuses
    Hautes Alpes - Parc National des Ecrins : La Froumentière
    Hôtel Augusta Club Spa **** Lloret de Mar Costa Brava
    Alpes de Hautes Provence: Hôtel Espace et restaurant Le Dormillouse

    These stick out more as to cause potential problems..

    July 23, 2018 at 7:17 pm
  • Michel
    Michel
    Newbie 18 points

    Bonjour James,

    I placed to Draft the 6 listings overthere: problem is still alive.
    But some of users copied and pasted texts that contain invisible HTML codes .
    So, I’ll check and clean all the published listing pages (132) and see…..
    Thanks James

    July 24, 2018 at 9:05 am
  • Michel
    Michel
    Newbie 18 points

    Hello James : WE GOT IT !!!
    As you said, the bug was due to an invalid code written by a user. But I was very malicious, because at first I placed temporary to trash all the listing pages that contain HTML code, but it was the same. Then I placed temporary to trash all the other listing pages except ten of them: Bug had desappeared !!! so step by step I identified the wrong listing page. (see attached file).
    Thanks a lot, James. Without your help, your perseverance, I won’t be able to fix it.
    Merci.
    Michel

    July 27, 2018 at 8:09 am
  • Michel
    Michel
    Newbie 18 points

    Invalid listnig page that contains 3 “stranges” codes…

    July 27, 2018 at 11:59 am
  • JamesD
    JamesD
    Super Guru 917 points

    Good to hear you fixed it Michel, good job!

    Invalid listnig page that contains 3 “stranges” codes…

    Was it these “strange” codes causing the problem or is this something else?

    July 27, 2018 at 6:36 pm
  • Michel
    Michel
    Newbie 18 points

    Hello James,
    I tried to send you the file but the file type was not permitted for security reasons.
    So I send you a png file.
    There was 3 invalids codes on the listing.
    On the main site (https://www.accueildegroupe.com) I had to remove the Facebook Plugin because sometimes Google map desapeared. Now all seems correct !!
    MERCI BEAUCOUP

    Attachments:
    You must be logged in to view attached files.
    July 28, 2018 at 12:36 pm
  • JamesD
    JamesD
    Super Guru 917 points

    My pleasure Michel.

    July 28, 2018 at 9:09 pm
Viewing 12 posts - 16 through 27 (of 27 total)

Didn't find what you were after?

Chat with us now

or contact our support team