SSL issue by Pagepeeker image url

WordPress Business Themes Forums Responsive Themes Coupon Theme SSL issue by Pagepeeker image url

Discontinued - The forum content is out of date. For theme support please use our support desk here.

SSL issue by Pagepeeker image url

May 10, 2019
 Amit

  • Amit
    Newbie 10 points

    My site CouponTaj.com is SSL enabled. But due to Pagepeeker image url’s my site is showing insecure url’s. Is there any resolution regarding this issue? Although I have submitted ticket regarding this issue more than one week ago but no resolution received till now.

    May 10, 2019 at 5:57 pm
  • JamesD
    JamesD
    Super Guru 1,351 points

    Hello Amit,

    You can make a couple manual changes, but it’s in a core file, so make a backup of the file first.

    There are 2 lines within the /CP9/framework/new_class/ppt_6_shortcodes.php file.

    Look around line #1364 & #1368 and you’ll see two pagepeeker links.
    Change the links to http to https.:
    http://api.pagepeeker.com
    http://free.pagepeeker.com
    Note: The original post had broke from the lines I added, so I removed them and am only displaying the beginning of the links to look for.

    May 10, 2019 at 7:18 pm

  • Amit
    Newbie 10 points

    I have done this before. After changing http to https the pagepeeker screenshots were gone. That’s why I changed them again to http. Doing this the store screenshots are not showing. What can I do in that case? Please help.

    May 10, 2019 at 7:54 pm
  • JamesD
    JamesD
    Super Guru 1,351 points

    @Amit
    Ok, I see. Unfortunately it looks like an upgraded ‘pagepeeker’ account would be needed or a Free unbranded one requesting a link back.

    Maybe someone else can chime in on their experience with it.

    Honestly, I wouldn’t think Mark would put something like PagePeeker in the theme if it requires additional fees in order to have secure pages, however I’m not 100%.

    Haven’t dug through all the code to see how everything is being handled, There may be caching or something else he’s doing to avoid using the direct non-secure link. Dunno.

    Not really sure what to expect anymore with PP themes. PagePeeker and Elementor have free versions, but to do things you think wouldn’t be too advance (or just work how you would expect) seems to require purchasing the upgrades.

    May 10, 2019 at 8:38 pm

  • Amit
    Newbie 10 points

    I have already subscribed a Free unbranded, limited to 100,000 API calls package from pagepeeker.com where SSL links is enabled but I couldn’t found where to change the API Key in my theme files. Have you idea about this? Please reply.

    May 10, 2019 at 8:52 pm

  • Amit
    Newbie 10 points

    It also Requires linking back to them. I don’t know how to link back to them.

    May 10, 2019 at 8:56 pm
  • JamesD
    JamesD
    Super Guru 1,351 points

    Have you turned on the PremiumPress > Configuration > Coupon Settings > PAGESEEKERS API setting?

    As far as the linking, I think putting their link anywhere within your site would work, but you may want to contact them for specifics.

    May 10, 2019 at 9:19 pm
  • JamesD
    JamesD
    Super Guru 1,351 points

    Also, SHOW POPUP COUPON WINDOW. must be turned on.

    May 10, 2019 at 9:23 pm

  • Amit
    Newbie 10 points

    I have turned on the PremiumPress > Configuration > Coupon Settings > PAGESEEKERS API setting and SHOW POPUP COUPON WINDOW. Also Added their link to my home page. But still screenshots are not generating.

    May 10, 2019 at 9:40 pm

  • Amit
    Newbie 10 points

    Now I have changed the urls as you mentioned earlier from http to https and the screenshots are showing but insecure url is still there.

    May 10, 2019 at 9:52 pm
  • JamesD
    JamesD
    Super Guru 1,351 points

    Go ahead and put it back to the original http.

    Have you added the site to your PagePeeker account under Sites?

    They offer a link to place on your site after you add a domain.

    I’m guessing you’ll need to finish the PagePeeker setup process first and verify the linkback link.

    May 10, 2019 at 10:21 pm

  • Amit
    Newbie 10 points

    Yes. I have added the the site in my pagepeeker account and it’s verified also.

    May 10, 2019 at 10:32 pm
  • JamesD
    JamesD
    Super Guru 1,351 points

    I haven’t seen any settings to add an API key or any place where the theme adds it to the url. Not sure if it’s a not fully developed process or if just the way it is type of thing.

    The only other thing (besides waiting for support) I can suggest to try would be to add &code=API_KEY to the to the API url.
    So, instead of

    <img src='http://api.pagepeeker.com/v2/thumbs.php?size=x&url

    it would look like

    <img src='http://api.pagepeeker.com/v2/thumbs.php?size=x&code=API_KEY&url

    Note: Be sure to replace the API_KEY with your PagePeeker api key.

    May 10, 2019 at 11:06 pm

  • Amit
    Newbie 10 points

    Great! I have added the API code in URL as you mentioned and replaced the http to https. Now the image url’s are serving over https. But here is a problem still remains. After login, https://www.coupontaj.com/wp-admin/ is serving over unsecured url.

    I have viewed the Page source and found that an URL i.e. http://dashicons%20dashicons-megaphone is shown there and the dashicon is also missing from the admin menu. This dashicon is attached to the Campaign tab in the menu. Can I change the URL from http to https in the theme file? If so then which file contains this url? Please help if any idea is available.

    May 11, 2019 at 6:19 am
  • JamesD
    JamesD
    Super Guru 1,351 points

    @Amit

    Can I change the URL from http to https in the theme file?

    Looks like a bug in the theme. It shouldn’t be a URL, just a reference to the icon.

    To fix it you can make a change in the core file /CP9/framework/new_class/ppt.php.

    Open up the file and look around line #179 for: 'menu_icon' => "dashicons dashicons-megaphone", and remove the first dasicons.
    It should look like: 'menu_icon' => "dashicons-megaphone",

    May 11, 2019 at 8:42 pm
Viewing 15 posts - 1 through 15 (of 17 total)

Didn't find what you were after?

Chat with us now

or contact our support team