Paid Listings Being Published Without Paying

WordPress Business Themes Forums Responsive Themes Directory Theme Paid Listings Being Published Without Paying

Paid Listings Being Published Without Paying

July 28, 2013
Adam Adam
  • Adam
    Adam
    Senior Member 142 points

    Getting further into testing now and am experiencing a few things. Will break them out into multiple threads here.

    I have activated live payment. Click subscribe on a paid package and get asked the expected questions. After “saving listing” I see the “Edit Listing” and “Make Payment” buttons.

    If I choose “Edit Listing” first, I am able to edit the listing with the included listing package enhancements (html editor, etc.)

    After I choose “save listing” the listing is immediately published!

    Even though I have not made a payment, and I have the listings set to “pending review”.

    Is this a bug?

    The expected behavior would be that after “saving”, if that listing had not been paid, that I would see the “Payment” button again and only after that would the listing come in as “pending review” and not published.

    July 28, 2013 at 3:38 pm
  • Adam
    Adam
    Senior Member 142 points

    Can someone else test this process and tell me if they experience the same thing?

    July 29, 2013 at 3:53 pm
  • Mark
    Mark
    Newbie 84 points

    Tested. Not an issue.

    Is it possible that you had memberships enables at one point for the user you are making listings for?

    Test version: 3.7

    July 29, 2013 at 6:27 pm
  • Adam
    Adam
    Senior Member 142 points

    I did have memberships enabled previously, but that was under a different admin user. This test was done with a completely new user email for testing.

    Thanks for having a look, I appreciate it.

    I don’t currently have any membership packages available, only listing packages. And the one I did have has since been deleted.

    I wonder what’s causing this on my setup???

    July 29, 2013 at 6:41 pm
  • Mark Fail
    Mark Fail
    Super Guru 12,812 points

    couldnt find any issues either, must be something you’ve setup.

    July 30, 2013 at 3:20 am
Viewing 5 posts - 1 through 5 (of 5 total)

Didn't find what you were after?

Chat with us now

or contact our support team