Francois

Listing Header

Hi there, I am using the Directory Theme V9.4.0 (No Child Theme). I created a Listing Page Elementor Template and the default Listing header disappeared. How can I get the Listing Page to show the default header again (with the small map, address etc)? I tried shortcodes and different elements with no luck. See "Default-Listing-Header.jpg" image what I mean. Thank you Francois

Created: November 26, 2019 at 2:22 pm
  • In: Directory Theme
  • Started by: FrancoisFrancois
  • 4 members left 16 comments
  • Last reply from: MarieMarie


  • Anonymous
    December 7, 2019 at 6:46 am

    Francois – it’s [SINGLE] Title Full Width under WordPress.

  • Francois
    Francois
    December 7, 2019 at 7:04 am

    Thanks very much Rene, just what I was looking for.

    Do you or anyone know how I can change the background image of the [SINGLE] Title Full Width widget? Currently it automatically uses the Main Image of the listing, but I want to set it to a custom image.

    I tried adding a background image with Elementor under the Advanced Tab, but it doesn’t seem to work – it still shows the listing’s default image which is poor quality.

    Thanks.


  • Anonymous
    December 8, 2019 at 5:18 am

    Sorry still battling that one myself 🙂 Will let you know if I find a fix.

  • JamesD
    JamesD
    December 8, 2019 at 10:43 am

    Hello,
    Do you or anyone know how I can change the background image of the [SINGLE] Title Full Width widget?
    Go to PremiumPress > Listings</em.
    Click the Edit link under the listing you want to change.
    Either click the Add Image/Video button under the File Attachments then select the image OR you can directly change the value of the Custom Field</em called image</em located.
    Save listing.

    Attachments:
    You must be logged in to view attached files.
  • JamesD
    JamesD
    December 8, 2019 at 10:44 am

    Hello,
    Do you or anyone know how I can change the background image of the [SINGLE] Title Full Width widget?
    Go to PremiumPress > Listings</em.
    Click the Edit link under the listing you want to change.
    Either click the Add Image/Video button under the File Attachments then select the image OR you can directly change the value of the Custom Field called image located.
    Save listing.

  • Francois
    Francois
    December 8, 2019 at 10:53 am

    Thank you JamesD

    But actuality I was looking at changing the image to a default background image for all listings. I see that editing the Listing Theme with Elementor has options for Background Image/Color, but it does not work.

  • JamesD
    JamesD
    December 8, 2019 at 10:47 pm

    Then you’ll need to edit a file.
    You’ll need to edit the core file.

    Either create a sub-directory in your child theme directory called widgets and copy the file /DT9/ into it then edit. (recommended method)
    OR
    Edit the core file /DT9/ itself.

    To edit… open the file you’re planning to use and at the top (around line #15) you’ll see <?php echo do_shortcode('[IMAGE pathonly=1][/IMAGE]'); ?>. Replace that line with the image URL you would like to use. Save the file and reload the page.

    Note: Don’t forget to make a backup of all files you edit before editing them!

    Hope it makes sense.

  • JamesD
    JamesD
    December 8, 2019 at 10:48 pm

    Replace that line with the image URL you would like to use. Save the file and reload the page.
    Sorry, didn’t mean the whole line, just replace that snippet portion.

  • Marie
    Marie
    December 9, 2019 at 2:36 am

    Thanks for sharing James 🙂


  • Anonymous
    December 10, 2019 at 9:49 am

    Thanks James -that solved my issue as well.


  • Anonymous
    December 10, 2019 at 9:55 am

    Francois
    I found that it still changes your background image so I deleted these as well
    <div class=”overlay”>
    <div class=”wrap”>
    <div class=”overlay2″>

    I then just changed the top margin in Elementor to accommodate the map. Hope that helps as I found this widget to be a bit too big for me.

  • Marie
    Marie
    December 11, 2019 at 9:57 am

    Thanks for sharing Rene 🙂

  • Francois
    Francois
    December 11, 2019 at 10:07 am

    Thank you all, appreciate a lot.

  • JamesD
    JamesD
    December 14, 2019 at 4:34 am

    @Francois @Marie
    You’re welcome.

    @Rene
    “I found that it still changes your background image so I deleted these as well…”
    Sounds like something was different.
    You shouldn’t have to remove any additional elements. Be sure to take care when removing elements, it could have unexpected results.


Viewing 15 posts - 1 through 15 (of 17 total)