Listing Custom Fields DB Key Names Wont Show Up In Advanced Search Fields

  • Randy
    Randy
    Newbie 16 points
    September 8, 2016 at 7:17 am

    Directory Theme:

    The custom fields I created for the Listing Form show and work great in the listings form and the listing as well.

    But when I try to use the listing custom fields to create searchable fields in the Advanced Search Fields, The Data Base Keys don’t show up for use.

    Note: I have followed PP Advanced Search Fields Video, and tried many ways to add an initial value to get the search field started, and to show up.

    I tried adding new listing, tried from admin panel, no matter what I do it won’t add a new database key search field to the list to use.

    I Even tried going back to the original directory default theme since I’m using a child theme, and tried it all again there.

    1. WHY IS MY DATABASE NOT ACCEPTING OR SHOWING THE CUSTOM FIELDS DB KEY NAMES IN THE ADVANCED SEARCH FIELDS FOR USE THERE ?

    2. Where do I check in the database to see if the database key names I created are even there or not? And what to do if there but not outputting for use.

  • Alex Morgan
    Alex Morgan
    Super Guru 1,111 points
    September 8, 2016 at 8:58 am

    Hi Randy,

    You have multiple topics with same issue. Please dont spam the forums please.

    Please submit a ticket for this issue so we can help you check your site.

  • Alex Morgan
    Alex Morgan
    Super Guru 1,111 points
    September 8, 2016 at 10:13 am

    Hi Randy,

    I am trying to help you and please submit a ticket for this issue. Please dont post rude comments on this community forums. Please.. This will be a warning.

  • Randy
    Randy
    Newbie 16 points
    September 8, 2016 at 10:14 am

    UPDATE
    I see that my database in the “postmeta” area does show all the database keys I tried installing with each custom field i created. So They are in the database but not showing in the ADVANCE SEARCH FIELDS area list to be able to make search fields out of them…

    WHY? and how can i make them visible for use?
    Thanks

  • Randy
    Randy
    Newbie 16 points
    September 8, 2016 at 10:25 am

    I’M TRYING FIRST “AS YOU REQUEST” TO GET MY ANSWERS THROUGH THE FORUMS FIRST.
    YOU SHOULD HAVE ALL THE ANSWERS TO MOST QUESTIONS BY NOW ANYWAY.. SO WHY NOT ANSWER THE QUESTIONS HERE IN THE FORUM SO EVERYBODY CAN SEE AND GET THE ANSWERS, AND NOT HAVE TO ENTER SUPPORT TICKETS.

    IF THE ANSWERS WERE HERE LIKE THEY SHOULD, I WOULD NOT HAVE TO DO A SUPPORT TICKET!

    THANK YOU

  • Alex Morgan
    Alex Morgan
    Super Guru 1,111 points
    September 8, 2016 at 10:54 am

    Hi Randy,

    They should show up automatically once you created a custom field under Listing setup > Custom fields. Then you add a listing with that custom field with value > this will then show up on that search field lists. That’s why if they dont show up on your end then we have to check.

  • Randy
    Randy
    Newbie 16 points
    September 9, 2016 at 10:16 pm

    PROBLEM IS A BUG THAT WAS IN THE VERSION THEME I HAVE,
    SOLUTION: UPDATE TO NEWEST THEME. AND ALL DATABASE KEYS SHOW UP.

  • Jason
    Jason
    Guru 837 points
    June 21, 2018 at 9:47 am

    From memory its all about the length of the DB name, it cant be more than from memory 22charators thats why wont appear when made to show for search page.
    Might be 20 or 21 or 22 charactors, not sure how mony but thats what I found,

    Any more than that wont show hence when making either CTAX or CFIELD always keep the DB name short

  • Mark Fail
    Mark Fail
    Super Guru 13,013 points
    June 22, 2018 at 2:38 am

    Thanks for updating Randy.

Viewing 9 posts - 1 through 9 (of 9 total)

New Business Themes for WordPress 2020

Start your new website today!

View Business Themes