Ask the community

This is a community support forum where you can ask
questions and interact with other PremiumPress Customers.

Google Fonts http security error

  • MD Salahuddin
    MD Salahuddin
    Newbie 48 points
    November 26, 2014 at 2:44 pm

    hi, the link: http://fonts.googleapis.com/….. as its is a http request causing security warning on IE. I have changed them to https of just //fonts… which I understand will be replaced on next update. so can any body suggest what can be done for a site with HTTPS


  • Josh
    Super Guru 13,885 points
    December 3, 2014 at 1:01 pm

    I suggest you open a ticket if still having the problem

  • Robin
    Robin
    Newbie 5 points
    June 10, 2016 at 2:21 pm

    Where did you edit the file – I’ve got the same thing (Google Font reference in header to an http link) causing mixed content problems.

    Anyone know what file is referencing link rel=’stylesheet’ id=’googleFonts-css’ href=’http://fonts.googleapis.com/css?family=Roboto%3A300%2C400%2C500%2C700&ver=4.5.2′ type=’text/css’ media=’all’/> ?

  • Mario
    Mario
    Newbie 16 points
    July 25, 2016 at 5:26 pm

    just replace http to https at
    /templates/template_directory_theme/_functions.php

  • Jason
    Jason
    Guru 836 points
    October 23, 2016 at 6:13 pm

    Mario, where is this what you say, nothing here.

    Pics attached

    This is where to check errors for SSL on sites. This is all referring
    to Google fonts not on SSL:

    https://www.jitbit.com/sslcheck/#

    Attachments:
    You must be logged in to view attached files.
  • Jason
    Jason
    Guru 836 points
    October 23, 2016 at 6:14 pm

    annother attached pic

    Attachments:
    You must be logged in to view attached files.
Viewing 6 posts - 1 through 6 (of 6 total)