Ask the community

This is a community support forum where you can ask
questions and interact with other PremiumPress Customers.

Facebook auto post plugin

  • Chris
    Chris
    Newbie 70 points
    August 20, 2013 at 2:30 am

    Hi,

    I use Ultimate Facebook plugin from wpmudev. It works great, it auto posts listings to my Facebook page/app however, it does not list the pictures. I have been told that it is a theme issue, the way this theme handles images. Is that true? What can I do to fix that?

  • Richard Bonk
    Richard Bonk
    Super Guru 2,739 points
    August 20, 2013 at 7:53 am

    You might want to ask the plugin developers if they can add the option to pick images from customfield as the PremiumPress themes use customfield ‘image’.

    Kind regards,

    Richard
    _____________________________________________________________________
    Wide range of PremiumPress and WordPress Plugins and add-ons
    PremiumPress customisation services and Website Design
    Selection of PremiumPress Child Themes

  • Chris
    Chris
    Newbie 70 points
    August 25, 2013 at 2:03 pm

    Plugin uses opengraph and first looks for featured image. If not found, it attempts to use first image in post, if not found if can be set to display an admin selected custom default image, such as site logo etc.

    I have asked if they will incorporate your suggestion above but it doesn’t seem likely. More likely they will suggest the theme dev incorporate the fix. 😉

    So, anyone know of any Facebook auto post plugins that allow posts made on the front end (like classifieds) that is capable of grabbing an image from custom field?

    Thanks in advance,
    Chris

  • Richard Bonk
    Richard Bonk
    Super Guru 2,739 points
    August 25, 2013 at 8:02 pm

    if it uses open graph, I have developed a plugin for PremiumPress themes that does include the correct image url in the opengraph metatags in the header:
    http://premiumwebservices.co.uk/shop/premiumpress-plugins/facebook-meta-for-premiumpress/

    Kind regards,

    Richard
    _____________________________________________________________________
    Wide range of PremiumPress and WordPress Plugins and add-ons
    PremiumPress customisation services and Website Design
    Selection of PremiumPress Child Themes

  • Chris
    Chris
    Newbie 70 points
    August 26, 2013 at 1:30 am

    Hi Richard,
    My hopes were up!
    Installed your plugin, still No image. :-(

    Attachments:
    You must be logged in to view attached files.
  • Richard Bonk
    Richard Bonk
    Super Guru 2,739 points
    August 26, 2013 at 10:15 am

    What is your site url? You can check the if the Open Graph Metadata is correct (and the right image passed) using the FaceBook Debugger tool: https://developers.facebook.com/tools/debug

  • Chris
    Chris
    Newbie 70 points
    August 26, 2013 at 11:55 am

    Facebook debug gives me:

    Scrape Information

    Response Code: 206
    Fetched URL: http://arabianhorseads.com/new
    Canonical URL: http://arabianhorseads.com/new/
    Errors That Must Be Fixed

    More Than One OG URL Specified: Object at URL ‘http://arabianhorseads.com/new/’ of type ‘article’ is invalid because it specifies multiple ‘og:url’ values: http://arabianhorseads.com/new/, http://arabianhorseads.com/new/.
    Redirect Path

    original: http://arabianhorseads.com/new
    301: http://arabianhorseads.com/new/
    Final URL is in bold (this is the URL we tried to extract metadata from).
    URLs

    Graph API: https://graph.facebook.com/157858747745316
    Scraped URL: See exactly what our scraper sees for your URL

  • Richard Bonk
    Richard Bonk
    Super Guru 2,739 points
    August 26, 2013 at 8:17 pm

    OK, there is error as you have the OpenGraph Meta tags generated twice, You have to disable it in one place (possibly in your Ultimate Facebook plugin).

    Kind regards,

    Richard

  • Chris
    Chris
    Newbie 70 points
    August 27, 2013 at 3:04 am

    Hi Richard,

    Appreciate all you do. I dunno, I think the world be a better place without the distraction of Facebook… however… it seems that is where you have to be to be seen.

    I turned off OG support in Ultimate Facebook plugin.
    A picture now gets posted but it is not the right one, it is the placeholder “no image available” picture.

    Probably easier just to post screengrabs!

    Attachments:
    You must be logged in to view attached files.
  • Chris
    Chris
    Newbie 70 points
    August 27, 2013 at 3:05 am

    And one more of debug

    Attachments:
    You must be logged in to view attached files.
  • Richard Bonk
    Richard Bonk
    Super Guru 2,739 points
    August 27, 2013 at 6:24 am

    On the FB Debug you see that the correct image is being provided (with the help of the FaceBook Meta for PremiumPress plugin) and I am quite positive that the right image will show if you post that link on FaceBook manually. But for some reason it does not work when you publish it using that Ultimate FaceBook plugin.

  • Richard Bonk
    Richard Bonk
    Super Guru 2,739 points
    August 27, 2013 at 6:27 am

    I personally use WP to Twitter plugin (http://wordpress.org/plugins/wp-to-twitter/ ) that posts automatically new published posts to twitter and then have the twitter linked to FaceBook and LinkedIn (so in fact it posts to all three in the same time).

    Kind regards,

    Richard

  • Chris
    Chris
    Newbie 70 points
    August 30, 2013 at 1:45 am

    Thanks Richard,

    Yes, Ultimate Facebook works like a charm on any theme that uses featured images, or if you include an image inline in the post. Unfortunately, this theme does not use either.

    Tried your workaround, took a bit of try and retry to get twitter auto posting to Facebook but I do (did…!) have it working. It seems kind of temperamental at best. Doesn’t seem to be a reliable way to accomplish what I’m after. If twitter stops sending or Facebook stops receiving because they can’t get along…

    There are other features in this plugin that I would like to use.

    I wonder if anyone could or would create a plugin for this theme that sets the first image posted for an ad to be featured image?

    Or… This new classifieds responsive theme, does it use featured image? Or does it handle images the same way?

    Cheers!
    Chris

  • Richard Bonk
    Richard Bonk
    Super Guru 2,739 points
    August 30, 2013 at 7:50 am

    The Responsive Themes use featured images.

  • Ahmed
    Ahmed
    Newbie 82 points
    August 30, 2013 at 9:58 am

    I have exactly the same problem and I have tried almost every plugin but still was not able to get my image published to Facebook.

    Add Link to Facebook plugin will send word press logo if it fails to find an image and again I have tried almost everything but fail to publish my product image to facebook

Viewing 15 posts - 1 through 15 (of 19 total)