Ask the community

This is a community support forum where you can ask
questions and interact with other PremiumPress Customers.

Every time I save a coupon I get an error message


  • Björn
    Newbie 4 points
    March 18, 2019 at 8:30 pm

    Hi, I use child theme for Coupon theme made with boiler.
    Suddenly I get this message every time I save/edit a Coupon.
    Is there a way to fix this?
    Message is:

    Warning: Illegal string offset ‘width’ in /home2/jbsdata/public_html/prisjagarna/wp-content/themes/CP9/framework/new_class/class_admin_design.php on line 195

    Warning: Illegal string offset ‘height’ in /home2/jbsdata/public_html/prisjagarna/wp-content/themes/CP9/framework/new_class/class_admin_design.php on line 196

    Warning: Illegal string offset ‘width’ in /home2/jbsdata/public_html/prisjagarna/wp-content/themes/CP9/framework/new_class/class_admin_design.php on line 197

    Warning: Illegal string offset ‘height’ in /home2/jbsdata/public_html/prisjagarna/wp-content/themes/CP9/framework/new_class/class_admin_design.php on line 197

    Warning: Cannot modify header information – headers already sent by (output started at /home2/jbsdata/public_html/prisjagarna/wp-content/themes/CP9/framework/new_class/class_admin_design.php:195) in /home2/jbsdata/public_html/prisjagarna/wp-admin/post.php on line 222

    Warning: Cannot modify header information – headers already sent by (output started at /home2/jbsdata/public_html/prisjagarna/wp-content/themes/CP9/framework/new_class/class_admin_design.php:195) in /home2/jbsdata/public_html/prisjagarna/wp-includes/pluggable.php on line 1251

    Warning: Cannot modify header information – headers already sent by (output started at /home2/jbsdata/public_html/prisjagarna/wp-content/themes/CP9/framework/new_class/class_admin_design.php:195) in /home2/jbsdata/public_html/prisjagarna/wp-includes/pluggable.php on line 1254

    Best Regards
    Bjorn

  • JamesD
    JamesD
    Super Guru 1,345 points
    March 19, 2019 at 4:07 am

    Hello Bjorn,
    They are warnings, so error reporting can be turned off without totally stopping execution.
    However, if you want to do proper and get rid of them altogether then upgrade to the current/stable PHP7. Or are you already running PHP7?

    Note: Assuming you’re referring to ‘CustomPhix Boiler”, so feel free to contact me directly via email. My contact info is in the boiler files.

  • Mark Fail
    Mark Fail
    Super Guru 12,822 points
    March 21, 2019 at 4:01 am

    What is Boiler?

    Can you provide more details.


  • Björn
    Newbie 4 points
    March 21, 2019 at 9:34 am

    Hi!
    Sorry if I was not clear on this.
    CustomPhix Boiler plugin. https://customphix.com/phix/boiler/
    Created my child theme with this plugin. Very neat.

    Is going to upgrade to php 7 on webserver to get rid of warnings.
    Tnx for help.

    /Bjorn

  • Marie
    Marie
    Super Guru 1,747 points
    April 5, 2019 at 6:32 am

    hi

    if you’re using version 9 , its highly recommended to use latest versions of PHP server versions too

Viewing 5 posts - 1 through 5 (of 5 total)