Details and comments tab not appearing on listing page

  • Michelle
    Michelle
    Newbie 16 points
    August 26, 2015 at 1:00 pm

    Hello,
    On my listing page the details and comments tabs are not appearing (screen shot attached). I was previously using Directory theme 8.4 and these tabs did appear then (screen shot attached). I am not an experienced coder (by any stretch of the imagination!) but I have examined the codes for the two pages in the page set up and all the code is exactly the same. I am (guessing) this is the key bit of code which features the same in both:
    <ul class=”nav nav-tabs” id=”Tabs”>

    <li class=”active”>{Description}

  • {Details}
  • Is anyone able to advise how I can get these tabs back as it means half the information on the listing is missing.
    Thank you,
    Michelle

    Attachments:
    You must be logged in to view attached files.
  • Nabeel
    Nabeel
    Newbie 3 points
    August 26, 2015 at 2:56 pm

    Hi
    This theme is awesome but the support team is not VERY Supportive. I am also working on this theme. It looks like the problem you are facing can be resolved by visiting as follows:

    Theme Options –> Page Setup –> Content Pages –> Listing Page Layout –> Then Select the drop Down as per desired results, save and check the front end.

    Please note if this helps you, please message back that it resolved the issue, so other people would benefit from this.
    Thank You

    This reply was awarded the best answer by the topic poster.
  • Michelle
    Michelle
    Newbie 16 points
    August 26, 2015 at 4:50 pm

    Thanks for that, I followed your advice and the tabs are now appearing, so much appreciated πŸ™‚

    When I now go to that section:
    Theme Options –> Page Setup –> Content Pages –> Listing Page Layout –>

    and select from the drop down I don’t get the code appear underneath anymore to do future edits. Maybe I’m meant to do it somewhere else now? I haven’t quite worked out how I actually get to the code of all the pages, do you know?

    I agree, the theme is really good, but if you are new to it all like me there is a lot to learn! I’ve found using this forum for problems is really good though.

  • Nabeel
    Nabeel
    Newbie 3 points
    August 27, 2015 at 11:19 am

    Hi,

    I’m glad it helped somewhat.

    “select from the drop down I don’t get the code appear underneath anymore to do future edits.” I think you are referring to “Use Custom Layout Option” in the drop down. Select this and then click bottom page “save” and then come back to the same screen i.e. Theme Options –> Page Setup –> Content Pages –> Listing Page Layout –> you can see the code underneath.

    All code pages are interlinked with shortcodes which are further interlinked with core framework files. This might be because the author is adding somewhat security layer to prevent code replica.

    I have now grasped pretty good understanding of it. I only bought it 2 days ago. Still performing autopsy.
    Thanks

  • Michelle
    Michelle
    Newbie 16 points
    August 28, 2015 at 9:55 am

    Hello, that is strange, I don’t seem to get the code appear again underneath, I’ve tried switching between different drop down options and saving them again, and going out of that section and back in again, but nothing seems to work at the moment. Oh well, at least all the information is appearing on the listing page now.

  • Prashanthi
    Prashanthi
    Newbie 22 points
    August 28, 2015 at 11:28 am

    Same issue here.

    I can not see the codes.

    I am using version 8.3


  • Josh
    Super Guru 13,875 points
    August 28, 2015 at 12:45 pm

    @Prashanthi From the dropdown select ‘Use Custom Layout’ and Save Changes for the codes to appear

  • Michelle
    Michelle
    Newbie 16 points
    August 29, 2015 at 8:46 am

    Hi Josh,
    That is strange, I am sure that wasn’t working for me before (in getting the code to appear) but it is now!

    But when I save it as ‘Use Custom Layout’ and then save changes and view the page I get the message “Warning: Illegal string offset ‘limit’ in /home/creati53/public_html/wp-content/themes/DT (9)/DT/framework/class/class_shortcodes.php on line 842” appear at the top. I also find the comments tab only half appears and doesn’t have the word ‘comments’ on it.

    If I go back to the ‘content-single-listing-mobile.php’ one and save that there are no errors but I don’t get the option to modify the code. Is that how it is meant to be?


  • Josh
    Super Guru 13,875 points
    August 31, 2015 at 2:30 pm

    @Michelle Try this code
    [code title=””]
    <div class=”block”><div class=”block-title”><h1><span>[TITLE]</span></h1></div><div class=”block-content”> [IMAGES] <span class=”right” style=”margin-top:7px; margin-right:20px;”>[CONTACT button=1] </span><ul class=”nav nav-tabs navstyle1″ id=”Tabs”> <li class=”active”>{Description}

  • {Details}
  • <div class=”tab-content”><div class=”tab-pane active” id=”t1″>[TOOLBOX]<h5>[TITLE]</h5>[CONTENT] [GOOGLEMAP] </div><div class=”tab-pane” id=”t2″>[FIELDS hide=”map”]</div></div></div></div> [COMMENTS box=1]
    [/code]
    Edit the code to your liking

  • Michelle
    Michelle
    Newbie 16 points
    September 5, 2015 at 11:33 am

    Hi Josh, thanks for sending that much appreciated, I’ve got that working and even managed to adjust the code to get it to display and not display things which is a leap forward for me πŸ™‚

    The only thing I can’t see how I can sort out is that when I view this page on my mobile and click on the ‘Details’ tab the table does not resize and goes off the screen to the right. Is there something I can add in to the code to solve this?

    Thank you

  • Viewing 10 posts - 1 through 10 (of 10 total)

    New Business Themes for WordPress 2020

    Start your new website today!

    View Business Themes