Ask the community

This is a community support forum where you can ask
questions and interact with other PremiumPress Customers.

Dating Site – questions on basic configuration


  • Ben
    Newbie 10 points
    June 6, 2019 at 2:09 pm

    Hello, I’ve raised a ticket for all these but thought I’d post it here in case existing users can answer more quickly and add additional information.

    1. Why have they created a dating theme using the word ‘listings’ instead of profiles? It’s such an obvious and easy thing to replace with the right word.

    2. Can the categories be used to denote sexual orientation so that people submit a profile can add it to one category only? Is that what other webmasters do with the dating theme?

    3. There are many version of the Google API for maps in the Google Developer control panel. Which one should I choose?

    4. I have set four membership packages but only three are visible. Why is that?

    5. Where do I change the theme’s default text, like “Only one you’ve confirmed your email will you be subscribed to our newsletter.”

    6. I have tested the default newsletter subscription. I receive the notification and click on the confirmation link but it returns a blank white page. Is there something I need to turn on to get this working?

    Thanks

  • JamesD
    JamesD
    Super Guru 1,345 points
    June 6, 2019 at 11:01 pm

    Hi Ben,

    1. Why have they created a dating theme using the word ‘listings’ instead of profiles? It’s such an obvious and easy thing to replace with the right word.

    There are settings at Settings > Common Settings > PremiumPress Custom Slugs.

    2. Can the categories be used to denote sexual orientation so that people submit a profile can add it to one category only? Is that what other webmasters do with the dating theme?

    Nothing available that’s “built-in” that I’m aware of.

    3. There are many version of the Google API for maps in the Google Developer control panel. Which one should I choose?

    Try the Maps JavaScript API

    4. I have set four membership packages but only three are visible. Why is that?

    Go to PremiumPress > Memberships and when you open up the setting and under Admin Extras you’ll see a Hide Package setting.
    06.06.2019-16.46.34

    5. Where do I change the theme’s default text, like “Only one you’ve confirmed your email will you be subscribed to our newsletter.”

    The language file is located here: /DA9/languages/premiumpress.pot

    Honestly, I’m not too familiar with using Loco Translate plugin myself, but from what I understand changes can be made with that.

    6. I have tested the default newsletter subscription. I receive the notification and click on the confirmation link but it returns a blank white page. Is there something I need to turn on to get this working?

    Make sure the Thank You page setting is a link to a validi page. Create the page if you don’t already have one.

    Here’s a tutorial that covers some basics with the Newsletter:


  • Ben
    Newbie 10 points
    June 7, 2019 at 4:56 am

    Thank you James. I can see why you’re a five star super guru! Clear, concise answers – what a refreshing change!

    I have experimented with PP themes for several years but haven’t used them for a couple of years so I’m out of practice. The one thing that I can see hasn’t changed is the number of spelling and grammatical errors both in the admin area and what the user sees.

    Can’t find this: Settings > Common Settings > PremiumPress Custom Slugs. – there’s no ‘Common Settings’ in my panel, either the WP or PP dashboard.

    I’m experimenting with this Loco Translate plugin. It certainly lists all the text and I can change, save, and sync but the changes aren’t reflected on the live site. All the indications are that the text has been changed and saved but no change when checked.

  • JamesD
    JamesD
    Super Guru 1,345 points
    June 7, 2019 at 7:35 am

    @jBen

    Can’t find this: Settings > Common Settings > PremiumPress Custom Slugs. – there’s no ‘Common Settings’ in my panel, either the WP or PP dashboard.

    It’s under the Permalink Settings.
    Settings > Permalink Settings > Common Settings > PremiumPress Custom Slugs.

    I’m experimenting with this Loco Translate plugin. It certainly lists all the text and I can change, save, and sync but the changes aren’t reflected on the live site. All the indications are that the text has been changed and saved but no change when checked.

    That’s actually why I haven’t messed with it too much. It’s not really priority and haven’t taken the time with it.

    I would think that some members have decent experience with it,. Whether or not they’ll chime in is another story.


  • Ben
    Newbie 10 points
    June 8, 2019 at 7:57 am

    I’ve worked out how to use Loco Translate to correct spelling and grammar (or change the text completely) in the English language file.

    Having fixed all the English ones the next task will be to find a way of translating and uploading a file for one or more other languages.

  • JamesD
    JamesD
    Super Guru 1,345 points
    June 8, 2019 at 9:59 pm

    Hi Ben,
    I’m not 100%, but I think this may be able to help:
    https://poedit.net/
    Looks promising. I’ll be taking a closer look later when I can find time to install it.
    There is a free version, Pro and Pro+. The cost doesn’t look bad for the pro/pro+.

    I’m thinking between Locos and POedit you’ll be able to accomplish what you need.


  • Ben
    Newbie 10 points
    June 9, 2019 at 7:07 am

    Thanks James. I will also take a look.

    First, I need to perfect the English file. Then I’ll experiment with the first language. Would be great if I can add several more and increase the reach of the site.

Viewing 7 posts - 1 through 7 (of 7 total)