Custom Menu

  • Mike
    Mike
    Titan 776 points
    August 4, 2013 at 10:48 am

    So have created a custom menu.

    As soon as I added child page links – the main link stops working.

    Any solutions?

  • Richard Bonk
    Richard Bonk
    Super Guru 2,739 points
    August 4, 2013 at 11:15 am

    Not sure I understand what you mean. Can you post a screenshot / link?

  • Mike
    Mike
    Titan 776 points
    August 4, 2013 at 11:19 am

    Sorry I dont want to put my site public on this forum. Thanks for your offer however.

  • Mark Fail
    Mark Fail
    Super Guru 13,013 points
    August 4, 2013 at 2:34 pm

    lol not sure we could help without seeing something..

  • Mike
    Mike
    Titan 776 points
    August 4, 2013 at 4:08 pm

    lol [frustrated] I issued a ticket several days ago….which has not been responded to.

    so I thought someone else might be able to help.

  • Mike
    Mike
    Titan 776 points
    August 4, 2013 at 4:08 pm

    now the 4th or 5th ticket which have not been answered!

  • Richard Bonk
    Richard Bonk
    Super Guru 2,739 points
    August 4, 2013 at 8:16 pm

    We would like to help you here on the forum, but it is quite difficult without knowing what the problem is.

    Can you at least describe the steps you are taking so we could try to emulate it on our systems?

    Also, did you try to disable all your plugins?

  • Mike
    Mike
    Titan 776 points
    August 4, 2013 at 11:02 pm

    Richard

    I’m not certain I can explain it any simpler if you look at the string of discussion.

    I have raised an Ticket with all the relevant links/logins/processes – hopefully that should be sufficient to explain what the problem is.

    I can see that there are several bugs in the scripts – but one of the problems of public forums is that it attracts spammers and other ne’er do wells out to make mischief – hence why I dont provide my links in this public forum…

  • Aaron
    Aaron
    Super Guru 920 points
    August 4, 2013 at 11:26 pm

    Screenshot? Actually I know what you are talking about.

    When you add a sub menu item in Menu Manager, the Main Menu Parent permalink gets removed.

    Not sure if this is by design or not.

  • Mike
    Mike
    Titan 776 points
    August 4, 2013 at 11:27 pm

    The steps taken were:

    I set up a custom menu
    I add links to each main link

    so it may look like this:

    Main Link
    sub link 1
    sub link 2
    sub link 3

    As soon as Sub link 1 is added – the link called Main Link stops working and when clicked does not go to the linked page.

    Remove all the sub links and the main link works again and when click goes to the page it is linked to.

    This is using the Square Business child theme – hope that is relevant?

    Hope that helps? 🙂

  • Richard Bonk
    Richard Bonk
    Super Guru 2,739 points
    August 4, 2013 at 11:28 pm

    OK, I understand now. This is by design – if you click on the main navigation menu it opens the submenu. It is not a fault.

    Kind regards,

    Richard
    _____________________________________________________________________
    Wide range of PremiumPress and WordPress Plugins and add-ons
    PremiumPress customisation services and Website Design
    Selection of PremiumPress Child Themes

  • Mike
    Mike
    Titan 776 points
    August 4, 2013 at 11:33 pm

    Richard

    We have crossed over….please see Aaron’s contribution – he’s got it – my exposition is a bit poor…. 😳 – sorry.

    Yes about detail…

  • Richard Bonk
    Richard Bonk
    Super Guru 2,739 points
    August 4, 2013 at 11:38 pm

    You can include the ‘main’ menu option in the ‘submenu’ with the other ‘sublinks’

  • Mark Fail
    Mark Fail
    Super Guru 13,013 points
    August 5, 2013 at 2:36 am

    Mike, if you submit multiple tickets via the ticket desk in an attempt speed things up, they just get deleted.

  • Mike
    Mike
    Titan 776 points
    August 5, 2013 at 9:37 am

    I think I did that because I wasn’t sure how to approach that particular topic – forum – ticket?

    But yes I thought they were deleted – thanks!

Viewing 15 posts - 1 through 15 (of 18 total)

New Business Themes for WordPress 2020

Start your new website today!

View Business Themes