CSV Download problem?

WordPress Business Themes Forums Version 7 Themes DirectoryPress CSV Download problem?

CSV Download problem?

July 5, 2013
Adrian Adrian
  • Adrian
    Adrian
    Newbie 20 points

    I downloaded a CSV file back in May and entered around 150 directory listings, which when imported was absolutely fine.
    Now I have another few hundred listings I want to put in, i’ve downloaded another CSV to populate.
    Now the CSV back in May was spanned across numerous columns and easy to populate, but the CSV i’ve just downloaded now has all column headers in cell A1, and all of the listings data just in Column A, seperated by comma’s, this is very different to the previous one I managed to download/re-import.

    Whats going on and how do I get the original back?
    Thanks

    July 5, 2013 at 12:49 pm
  • Adrian
    Adrian
    Newbie 20 points

    Temporarily solved this by selecting column A and doing Data > Text to columns…

    But would still like to know why it didn’t export this way in the first place when it did first time round.

    Thanks

    July 5, 2013 at 2:46 pm
  • Richard Bonk
    Richard Bonk
    Super Guru 2,739 points

    What software do you use to open the csv file? As csv has no structure (it’s a list of comma separated values) so it is up to the software that opens that file to put it into columns and rows. Make sure that the file is ending in .csv as otherwise it might not be recognised correctly.

    July 5, 2013 at 7:09 pm
  • Mark Fail
    Mark Fail
    Super Guru 12,812 points

    Glad you got it sorted.

    July 6, 2013 at 12:10 am
  • Adrian
    Adrian
    Newbie 20 points

    @Richard – I use Excel 2003 which is what I also used first time round so not sure why it’s behaving differently.

    July 8, 2013 at 8:45 am
  • Richard Bonk
    Richard Bonk
    Super Guru 2,739 points

    Adrian, this is a relatively common problem and you might want to look it up in Google. Here is one possible solution: http://help.lockergnome.com/office/problem-opening-csv-file–ftopict225326.html

    Kind regards,

    Richard

    July 8, 2013 at 9:15 am
  • Adrian
    Adrian
    Newbie 20 points

    Thanks, checked regional settings on this PC (The one that it opened funny on) and the list separator is already set to comma, but as said before the temporary fix of text to columns worked for me.

    July 8, 2013 at 9:30 am
  • Richard Bonk
    Richard Bonk
    Super Guru 2,739 points

    Other option is to add an extra line to your CSV file to tell Excel what the separator is. Add the following line to the top of your CSV file:

    sep=,

    This will tell Excel to use the “,” character as separator for the next lines. This first line is considered an instruction and not shown in your Excel sheet.

    July 8, 2013 at 9:45 am
Viewing 8 posts - 1 through 8 (of 8 total)

Didn't find what you were after?

Chat with us now

or contact our support team