Cant set Correct Location In Geolocation

  • Mike
    Mike
    Titan 776 points
    April 9, 2015 at 1:52 pm

    The Geolocation seems to only set as the base the location of the web site owner and not where the User is.

    So our office is Gibson Sq.

    Would I be correct that this is currently being fixed because of the redirect issue?

    Should I tell my Users to manually update their location?

  • Alex Morgan
    Alex Morgan
    Super Guru 1,111 points
    April 9, 2015 at 3:46 pm

    Hi Mike,

    Yes it will be based on the user ip. Can I suggest that you submit a ticket for this so Mark can take a look at this matter please? This should be a good enhancement for the geolocation.

  • Mike
    Mike
    Titan 776 points
    April 9, 2015 at 5:55 pm

    Hi Alex

    It does not pick up the IP – it seems to recall the last entered location updated by any User!

    I’ll test it some more and report back. I just wonder if it is just on this particular installation.

  • Alex Morgan
    Alex Morgan
    Super Guru 1,111 points
    April 9, 2015 at 6:01 pm

    Hi Mike,

    Sorry I checked again on demo and it gets my correct location, I thought you referring to it just get the location of the ISP but by default it works well and it directs to the current user location perfectly.

    This reply was awarded the best answer by the topic poster.
  • Mike
    Mike
    Titan 776 points
    April 9, 2015 at 10:58 pm

    Hi Alex

    Bizarrely mine does not.

    It seems to have been stuck in the same base location. But one of my sites works fine as you describe and the other does not.

    It may be that my cache plugin is holding the location data.

    Wont switch off the cache because Theme query is still poor and slow.

    I will test and see and revert as I find out.

  • Mike
    Mike
    Titan 776 points
    April 10, 2015 at 6:07 am

    Hi Alex

    Looking again today – it appears that my cache has been guilty of retaining the last updated location!

    I will get me colleagues to continue their tests in other locations to see how well the IP recognition aspect works.

    Second line testing shows it working extremely well.

    Unlike my email alerts from this forum.

    thanks for your help meantime.

  • Alex Morgan
    Alex Morgan
    Super Guru 1,111 points
    April 10, 2015 at 6:49 am

    You’re welcome Mike 🙂

  • Mike
    Mike
    Titan 776 points
    April 14, 2015 at 6:17 am

    Alex

    It is still an issue – but I can see it is being addressed.

    thanks for help.


  • Alexander
    Newbie 4 points
    April 19, 2015 at 3:59 pm

    Hi! I have the same issue with an Geolocation. In my case system use “Afghanistan” as an pre-defined location every time.


  • Josh
    Super Guru 13,875 points
    April 19, 2015 at 4:06 pm

    @Alexander go to Theme Options >General Setup >GEO Locations /Maps > GEO Location >Display GEO Flag and select your Country from the dropdown


  • Alexander
    Newbie 4 points
    April 19, 2015 at 5:11 pm

    Hi Josh,

    Thank you so much – it works. Really appreciate your fast assistance.


  • Josh
    Super Guru 13,875 points
    April 19, 2015 at 5:43 pm

    Your welcome.Glad i could help 🙂

  • Alex Morgan
    Alex Morgan
    Super Guru 1,111 points
    April 20, 2015 at 8:05 am

    🙂

  • Jacob
    Jacob
    Newbie 9 points
    May 29, 2015 at 8:54 pm

    Looks like I am a little late to this conversation. This feature still doesn’t work for me. I’ve tested my directory from 2 or three different computers and different browsers in different states and without manually changing my location the directory thinks I’m about 4500 miles from where I am. I’m at a loss as to how to address the issue. Any additional insights would be appreciated!

Viewing 14 posts - 1 through 14 (of 14 total)

New Business Themes for WordPress 2020

Start your new website today!

View Business Themes