Add to cart button is not showing in the listing page

  • Nick
    Nick
    Newbie 11 points
    March 9, 2015 at 7:57 pm

    Updated shop theme today

    its great that the add to cart button now adds it to the cart , but inside the listing its completely diapered ( in the listing page you just see ” [ADDBIG] ”

    going to include a screen shot

    hope this is an easy fix . if somone wants to buy but first wants to view the listing now they need to go back to find it on the home page to be able to add to cart

    Nick

    Attachments:
    You must be logged in to view attached files.

  • Matthew
    Newbie 3 points
    March 9, 2015 at 8:17 pm

    Same here, no “add to cart” or options for colour or size dropdowns are visable after the latest update. So im now left with a broken shop aswell.

  • Nick
    Nick
    Newbie 11 points
    March 9, 2015 at 8:21 pm

    Please any help with this would be great


  • Josh
    Super Guru 13,875 points
    March 9, 2015 at 8:26 pm

    Hello Guys
    Try [ADD]

    This reply was awarded the best answer by the topic poster.
  • Nick
    Nick
    Newbie 11 points
    March 9, 2015 at 8:42 pm

    yes this worked for me

    just in-case you dont know where to change that here is some help

    click . Page set up
    Click . the tab . Content Pages
    click . Listing page Layout

    then in the code box find the bit thats says [ADDBIG] and just remove the word BIG
    You will then have [ADD]
    Save changes and your done


  • Matthew
    Newbie 3 points
    March 9, 2015 at 8:48 pm

    https://worldofrave.co.uk/product/world-rave-kids-t-shirt-colour-design/

    What do you mean try [ADD] ?
    On the product manager it shows no [ADDBIG] or any options.

    By adding [ADD] to the product Main information box it puts a “add to cart button” but doesnt show any options/dropdowns for “attributes” like it used to.


  • Matthew
    Newbie 3 points
    March 9, 2015 at 9:05 pm

    Thanks Nick fixed mine which have attributes dropdowns by going to –

    Page set up > Tab Content pages > Listing page layout on the left > and choosing > content-single-listing-shop.php

    All Attributes and dropdowns are back to normal.


  • Josh
    Super Guru 13,875 points
    March 9, 2015 at 9:25 pm

    Thanks for sharing Matthew 🙂


  • Janak
    Super Guru 1,283 points
    March 11, 2015 at 1:35 pm

    Changing ADDBIG to ADD gets the add cart button back but doesn’t get the Price, Quantity or Attributes back. They are all missing but were present before upgrading from version 8.0.

    Also another problem – it’s great that the Add Cart button works from the results page but if you have attributes set up (eg. colour) it just goes ahead and adds it to the basket without any attributes. It should first check if there are no attributes set up for an item before adding to basket and if there are attributes it should just take you to the item.

  • Russell
    Russell
    Newbie 8 points
    March 15, 2015 at 5:31 pm

    I had this same issue of all “Add To Cart” buttons across my site not working after upgrading to Shop 8.1. I had been using the “Content Pages/Listing Page Layout/Use Custom Layout” option with the embedded ADDBIG code. I changed the option to “content-single-listing-shop.php” and this restored the buttons in a totally different listing page screen format that works again. I liked my screen format better with the “Use Custom Layout” option, but when I went back to that option, none of the shortcodes, including ADDBIG, were there anymore. All of the old custom codes were gone, so I am unable to try changing ADDBIG to ADD. My advice, which I wish I had followed (hindsight=20/20, right?!) is to copy and save those custom layout codes before trying the “content-single-listing-shop.php” option in case you want to go back and try out the ADD change.


  • Josh
    Super Guru 13,875 points
    March 15, 2015 at 5:46 pm

    @Russell here is the code
    [code title=”code”]
    <div class=”panel panel-default”><div class=”panel-body”><h1>[TITLE-NOLINK]</h1>
    <hr />
    <div class=”row”>
    <div class=”col-md-6″>[IMAGES]</div>
    <div class=”col-md-6″> [EXCERPT] <hr /><div class=”lead”>[price]</div> [ADDBIG]</div></div>
    <hr />
    <ul class=”nav nav-tabs navstyle1″ id=”Tabs”>
    <li class=”active”>Product Description

  • Comments
  • <div class=”tab-content”>
    <div class=”tab-pane active” id=”t1″>
    [TOOLBOX]
    [CONTENT]
    [GOOGLEMAP]
    </div>
    <div class=”tab-pane” id=”t4″><br />
    [COMMENTS]
    </div>
    </div>
    </div> </div>
    <h4>Related Products</h4><div class=”clearfix”></div><hr>
    [RELATED carousel=true]
    [/code]

  • Russell
    Russell
    Newbie 8 points
    March 15, 2015 at 7:25 pm

    Josh, thanks for the quick response. That wasn’t what showed before, though, in the green editable shortcode box that used to include the ADDBIG code bit that you & Nick suggested changing to BIG. That green box doesn’t show up now when I switch back to the “Use Custom Layout” option for Listing Page Layout. That section of the window just shows blank white space – no green box showing suggested code bits like it did before (see attached screenshot).

    Attachments:
    You must be logged in to view attached files.
  • Russell
    Russell
    Newbie 8 points
    March 15, 2015 at 7:37 pm

    @Josh, thanks for the quick response. That wasn’t what showed before, though, in the green editable shortcode box that used to include the ADDBIG code bit that you & Nick suggested changing to BIG. That green box doesn’t show up now when I switch back to the “Use Custom Layout” option for Listing Page Layout. That section of the window just shows blank white space – no green box showing suggested code bits like it did before (see attached screenshot).

    @Josh, does that code give me the green box back? If so, what file name do I give it and where do I put it? Appreciate your patience, and help. Thanks.

    Attachments:
    You must be logged in to view attached files.

  • Josh
    Super Guru 13,875 points
    March 15, 2015 at 7:58 pm

    Under Listing Page Layout select ‘Use Custom Layout’ from the dropdown Save Changes.After you save some code will appear and a Reset button.You can press the reset button or use the code i provided above

    Attachments:
    You must be logged in to view attached files.
  • Russell
    Russell
    Newbie 8 points
    March 15, 2015 at 8:05 pm

    @Josh, got it, that solved it! I’m back to my preferred custom layout, using the ADD rather than the ADDBIG bit. Many thanks!

  • Viewing 15 posts - 1 through 15 (of 26 total)

    New Business Themes for WordPress 2020

    Start your new website today!

    View Business Themes