JANUARY SALE: Directory Theme Now Only $49 -- Learn More

Ask the community

This is a community support forum where you can ask
questions and interact with other PremiumPress Customers.

Website screenshot settings – setting up the API


  • Viresh
    Newbie 8 points
    June 17, 2016 at 5:32 pm

    Hi

    I tried setting up the above plugin – it requires Google API settings to be entered. The screenshots seem to be for an older setup of Google and I wasn’t able to follow these instructions exactly as the menu options have all changed.

    I’ve done the best I can, but when I view my listing on the site, instead of seeing a screenshot of the website, I see this error
    Website Screenshot Error
    The referrer null does not match does not match the referrer restrictions configured on your API key. Please use the API Console to update your key restrictions.

    Please can someone help me with step-by-step instructions on how to set up the Google API so that I can view the thumbnails instead of the error message.

    Thanks

  • Wayne
    Wayne
    Newbie 30 points
    July 1, 2016 at 11:30 pm

    Same problem


  • Josh
    Super Guru 13,885 points
    July 5, 2016 at 4:35 pm

    Hello Viresh,
    While logged into your Google account go to >https://code.google.com/apis/console/ >under ‘Other popular APIs’ select ‘PageSpeed Insights API’ >Create a Project

  • Trishah
    Trishah
    Newbie 9 points
    November 23, 2016 at 12:08 am

    I’m trying to setup Google Pagespeed API and the tutorial looks nothing like what I see at: https://code.google.com/apis/console/ I’m going around in circles and can’t figure out where to get the key.


  • Josh
    Super Guru 13,885 points
    November 23, 2016 at 1:54 pm

    Hello Trisha,
    Have a look at this >>http://www.premiumpress.com/blog/setup-google-maps-api-key-wordpress/
    Its the same process


  • ken
    Newbie 8 points
    September 13, 2017 at 6:57 pm

    Hi,
    going around in circles a bit…..
    Finally got the Google Maps to work but having problems with the Screen Shots, please tell me which Google API(s) I need to Enable to make this work as you have several showing in the General Setup demo.

    Attachments:
    You must be logged in to view attached files.

  • Josh
    Super Guru 13,885 points
    September 14, 2017 at 1:33 pm

    Hello Ken,
    Please use below steps:
    1.Navigate to https://code.google.com/apis/console
    2.Login with your Google Account (Create a Google account if you do not have one)
    3.Click the “Create Project…” button
    4.You should now be looking at the “Services” page, if you are not, click “Services” from the menu on the left.
    5.Scroll down the Services page until you find “PageSpeed Insights API”. Click the Switch to turn it on. You must agree to Google’s Terms and Conditions to continue.
    6.After enabling the API, navigate to the “API Access” page from the left menu. Your API Key can be found under “Simple API Access.” Copy this key to your clipboard.
    7.Paste this API Key into the Options page of Google Pagespeed Insights for WordPress


  • ken
    Newbie 8 points
    September 14, 2017 at 6:14 pm

    Hi Josh,
    what you write is not what I see when going into the console?
    Please see image included.

    I keep trying various ways but with no joy, to be honest, the process should be very simple and straight forward; perhaps it is to others but it’s taking its time to sink in with me….

    Also, please tell me where this part is as I have been entering the code into the Theme Settings/Plugin-Website Screenshot Settings?
    ***************************************************************************************
    7.Paste this API Key into the Options page of Google Pagespeed Insights for WordPress

    Attachments:
    You must be logged in to view attached files.

  • ken
    Newbie 8 points
    September 14, 2017 at 6:30 pm

    Turned the debug off and now it appears to work???

    Thanks Josh btw – much appreciated.


  • Josh
    Super Guru 13,885 points
    September 15, 2017 at 12:20 pm

    Thanks for updating Ken :)

Viewing 10 posts - 1 through 10 (of 10 total)