Jasper

Trying to fix 500 Internal Server Error

Hi all I have a very serious problem with my website Shoppingdeals4u.com; the dreaded 500 Internal Server Error. And the very insistent sort, it's been like this for several days now and I can't figure out how to fix it. The status right now is that I can access the Wordpress admin area (but very slow), but the main site returns the 500 Internal Server Error. The following has been done, replace .htaccess file and disabled all plugins. After I had renamed the .htaccess file I was able to access the admin area where I disabled all plugins. This however has not fixed the error. I have the Responsive Framework version 6.5.6 of the Coupon Theme, using child theme Coupon Orange (from March 2014). I know it's an old version but I used to have tech issues with with updating that's why I did not go to the later versions. The first problems with the server error started occurring around 1st of May, this is also when I updated Wordpress to the latest version. I now have version 4.2.2. Are there known issues with older versions of the framework? I use shared hosting with Godaddy. They were helpful in the initial stages to get the admin area back up but according to them the problem is with the coding in my site and I am not good enough with coding to attempt to solve this myself. One other thing the hosting tried was to switch to the default theme and that resulted in the site working (but without any content). If I look at the error log, with the limited knowledge I have about this, it also seems to point to an issue with the theme. Here is the error that most frequently occurs: 12-May-2015 18:12:35 Europe/London] WordPress database error Lost connection to MySQL server during query for query SELECT meta_key FROM wp_postmeta WHERE meta_key !='_wp_page_template' AND meta_key !='_edit_last' AND meta_key !='_edit_lock' AND meta_key !='_encloseme' AND meta_key !='_pingme' GROUP BY meta_key made by require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/CP656/index.php'), white_label_themes->ITEM_CONTENT, white_label_themes->CUSTOMFIELDLIST I attach a zip version of the error log to this post. I hope someone on here can help me get the site back up and running. This situation is really painful. Jasper

Created: May 12, 2015 at 5:42 pm
  • In: General Discussion
  • Started by: JasperJasper
  • 5 members left 10 comments
  • Last reply from: Shawn

  • JamesD
    JamesD
    May 13, 2015 at 12:52 am

    Hi Jasper,
    From glancing at the log it looks like a possible “overload” issue (not enough resources, memory leak… etc).

    Have you verified that the server resources are sufficient enough?
    Note: In WP Admin go to “Theme Options >> Overview >> PHP Check” and see if there are any red marks.

  • Aaron
    Aaron
    May 13, 2015 at 12:57 am

    Allowed memory size of 67108864 bytes exhausted.

  • Jasper
    Jasper
    May 13, 2015 at 7:53 am

    Thanks for the replies. I increased the resources on my hosting account on 1 May and specifically asked Godaddy this week if the resources on my account were adequate and they say they were. I take it they’re not?

    In PHP Check in the dashboard everything is green
    Max Execution Time 120
    Memory Capacity Limit 256m
    POST Form Maximum Size 48m

    Changing the theme the default theme Twenty Fifteen brings up the site. Can it be theme related or is it the server resources?

  • Mark
    Mark
    May 13, 2015 at 8:50 am

    @Jasper, as it was said earlier, error 500 is related to the server running out of resources (it is not necessarily the main memory that you might be short of).
    The things that you should look at to determine which part is so ‘resource hungry’:
    How many coupons do you have?
    How many coupon categories?
    How many different custom fields are there created?
    Do you use any widgets? (try to remove all)
    Do you use any ‘Home Page Objects’? (try to remove all)
    How many WordPress menus do you have? (and how big they are)
    Have you tried switching just to the parent theme?

    Mark

  • Aaron
    Aaron
    May 13, 2015 at 9:35 am

    The log states the exact error:

    Try adding this line to your file in between the php tags:
    define(‘WP_MEMORY_LIMIT’, ’128M’);

    If this fails-

    Add/edit the file in your hosting root:
    memory_limit = 128M ;

  • Jasper
    Jasper
    May 13, 2015 at 9:45 am

    @Mark

    Thanks for the good suggestions, I will do it.
    I had quite a lot of plugins and homepage objects running but now, with all these disabled, I still get the 500 Internal Server Error.

    Switching to just the Parent Theme (Coupon Theme ) I manage to bring up the site once or twice but if I click on anything I get again the 500 error. If I switch to Twenty Fifteen theme then it works.

    Is what I plan to do going to fix the problem you think? What I plan to do is this: upgrade to the newest version and more or less build it up from scratch, taking care to use as little plugins and homepage objects as possible (whilst trying to keep functionality and user friendliness etc).
    I have about 1100 coupons. I use mainly WP Allimport to import these from affiliate networks. Apart from creating the coupon text, this plugin creates quite some custom fields in the background when it imports (for example image, Yoast Seo fields, category, store etc.).

    But because we are not talking about hundreds of new coupons at the time I didn’t think this was a problem. If I could avoid it I would not like to delete old coupons because they have rankings in Google (although every day that the site isn’t working I lose more of these). Is there a ‘clean’ way to deal with this, to remove old ones?

    My hosting is up for renewal very soon. Do you suggest moving to another provider?

    Thanks
    Jasper

  • Jasper
    Jasper
    May 13, 2015 at 10:11 am

    @Aaron: I already have this in , see below

    = “On”
    magic_quotes_gpc = Off
    magic_quotes_runtime = Off
    magic_quotes_sybase = Off
    file_uploads = On
    post_max_size = 100M
    upload_max_filesize = 100M
    memory_limit = 128M
    max_file_uploads = 200
    max_execution_time = 5000

    Still add to wpconfig as well?

  • Aaron
    Aaron
    May 13, 2015 at 1:02 pm

    Yes add it to your wpconfig and yes wpallimport and shared hosting don’t mix very well – try processing 20 records per iteration.

  • Jasper
    Jasper
    May 13, 2015 at 5:36 pm

    @Aaron, I had to go down to 8 records per iteration to get it to work, and the 128MB limit was already there (although not sure if it was in the right place, but think it is now).

    Still get the error. Going to get a maintenance screen up now and start the process of trying to fix this, simplify the technical structure, and find new hosting.

    @Mark; yes if you put it like that, it’s not so surprising it takes up some resources.


  • Shawn
    May 15, 2015 at 5:58 am

    I’m jumping in a little late on this one but maybe this will help.
    Depending on the type of hosting you have with GoDaddy you will have to name the file either

    .
    (note the “.” before the user, it’s important)
    I found this:

    The .ini file is like a valve, the server may be delivering 2 gig but the valve is only set to 128M.
    Then use a file to display what your server is really running at.
    Here is how to make a file:

    Upload the file to your root folder (usually / or public_html) then open your browser to
    You should see a long page of settings. The settings you need will be there, you may want to command F (control F) to find your setting. One side will show what your server will put out the other shows what you have your .ini set at. Study it a bit and you’ll get it.
    I will agree with the comments on shared hosting and resources, VPS/Dedicated is the way to go when you start to get big.
    You may also want to try disabling your .htaccess file. If that is stacked up with code it can cause 500’s.
    I’m a little curious to how much traffic you are seeing Jasper? I host with GoDaddy and I have sites on their shared cPanel and Managed WordPress.


Viewing 11 posts - 1 through 11 (of 11 total)