Shopping cart empty bug – how do I fix it?

WordPress Business Themes Forums Version 7 Themes ShopperPress Shopping cart empty bug – how do I fix it?

Discontinued - The forum content is out of date. For theme support please use our support desk here.

Shopping cart empty bug – how do I fix it?

July 26, 2013
Dan Dan
  • Dan
    Dan
    Newbie 66 points

    http://www.thegadgethut.co.uk
    Its an amazon affiliate website.

    on and off there is a bug where after clicking ad to chart then checkout it returns the page /checkout and says your shopping cart is empty.

    Ive tried many things. Ive removed all the plugins but still not luck. Ive re-installed them and turned them off for the min but still no luck.

    However if you then click around on the site e.g. “home” it re-populates the cart (in the bar at the top) and you can then click it and checkout…

    July 26, 2013 at 1:28 pm
  • David Harris
    David Harris
    Senior Member 367 points

    There has been a few posts on this, try a search.

    July 26, 2013 at 1:56 pm
  • Dan
    Dan
    Newbie 66 points

    I have, but nothing is fixing the issue.

    I was hoping the theme developers could take a look somehow

    July 26, 2013 at 2:13 pm
  • Ian
    Ian
    Super Guru 1,200 points

    It’s when you click on checkout too quickly.

    July 26, 2013 at 11:13 pm
  • David Harris
    David Harris
    Senior Member 367 points

    It’s a hosting thing if you ask me, how the script is run and php sessions. If run using apache-mod_php all is tickety boo but using FCGld ( fast cgi ) this can happen.

    Hassle your hoster until they get off their butts and look at it and give you a positive answer.

    July 27, 2013 at 4:12 am
  • Mark Fail
    Mark Fail
    Super Guru 12,814 points

    yeh some times the ajax is slow to click in so the user clicks so fast the site hasnt had chance to update the basket and they are already moving packages.

    July 27, 2013 at 6:13 am
  • Richard Bonk
    Richard Bonk
    Super Guru 2,739 points

    Isn’t fact-cgi supposed to be ‘fast’?

    July 27, 2013 at 8:04 am
  • David Harris
    David Harris
    Senior Member 367 points

    lol, apache-mod_php is faster but creates some possible security issues ( apparently )

    All my systems default to fast cgi and hardly ever a problem, just this empty basket quirk at times, it seems to come and go, the mind boggles.

    Nginx with fast cgi is meant to be faster but never tried it.

    July 27, 2013 at 8:50 am
  • Waihung
    Waihung
    Newbie 15 points

    I am having a similar issue. When a “guest user” adding items into the shopping cart, the shopping cart counter and price on the sub-menu are messed up. They don’t add up right. And when I click on the cart icon, it says my cart is empty. But It will still say I have something and price in my cart on the sub-menu next to the cart icon. I can’t get to it and delete them because when I click it, it says I have nothing in my cart.

    Any one having a similar issue?

    Thanks,
    Daniel

    August 17, 2013 at 8:06 am
  • Dan
    Dan
    Newbie 66 points

    Are you using caching?

    Also are you adding to your cart and clicking checkout too quickly?

    I heard shopperpress and ajax requests to the server are the issue.

    August 17, 2013 at 7:21 pm
  • Waihung
    Waihung
    Newbie 15 points

    I just turned off all plug-in and did a test. I am not using caching. The result is negative.

    As a guest user (not logged in), I add a few items in my shopping cart, they show up in my sub-menu bar, where the icon is, but only under a few main menu bar. If I go to another main menu, the shopping cart tells me I have 0 items. When I click the shopping cart icon, it says I have nothing. I can not remove them because I can not get to them.

    The other big problem is, when a guest user add items to shopping cart, another guest user from another computer can see the items in their shopping cart.

    Can you also explain what is ajax? I am kind of new to all these.

    How did you fix the problem on your site?

    Thanks,
    Daniel

    August 17, 2013 at 8:02 pm
  • Waihung
    Waihung
    Newbie 15 points

    Please take a look at http://www.hoveylee.com when you have a chance. Thanks

    August 17, 2013 at 8:04 pm
  • Waihung
    Waihung
    Newbie 15 points

    There was a glitch in the wp-super-cache plugin. Deactivating it did not work. Removing it fixed the problem after all.

    -Daniel

    August 18, 2013 at 12:45 am
  • Dan
    Dan
    Newbie 66 points

    Nice website. Good clean look.

    August 22, 2013 at 5:58 pm
  • Ratan Chandra
    Ratan Chandra
    Newbie 10 points

    Hi all,
    I fixed the problem.
    Just General Setup> Top Navigation. Select html view under Headert Layout.
    Then select menu+cart layout under Main Menu tab.
    Save and ok.

    If any problematic, then knok me here.

    August 7, 2016 at 11:51 am
Viewing 15 posts - 1 through 15 (of 17 total)

Didn't find what you were after?

Chat with us now

or contact our support team