Shally

Premiumpress – Apache to Nginx + PHP-Fpm

I change my server from apache to Nginx + PHP Fpm (VestaCP) and I upload my website to the server. I thought there is a problem with my backup but both my premiumpress website is giving 502 BAD GATEWAY. My other website running on normal theme and woocommerce is fine. Can help me how to fix this?

Created: March 16, 2020 at 7:33 am
  • In: General Discussion
  • Started by: Shally
  • 2 members left 3 comments
  • Last reply from: AdnanAdnan

  • Adnan
    Adnan
    March 16, 2020 at 10:57 am

    Hi Shally,

    This has most probably nothing to do with premiumpress theme. My PP theme is also running with nginx + php fpm. Check your nginx configuration and settings. Be aware that .htaccess files don’t work with nginx,


  • Shally
    March 17, 2020 at 12:29 am

    No problem with Nginx configuration.
    I tested on 1 of my website;
    1. I disable PP theme and it works fine.
    2. I enable PP theme and it is broken.
    3. PP version is and I remove the old and put version 9. It is working but the whole website have to be reconfigure.

    Any info on how make it works for version

  • Adnan
    Adnan
    March 18, 2020 at 3:07 pm

    I would check the nginx error log.

    Can be a php7 issue, some early versions of had issues with it.


Viewing 4 posts - 1 through 4 (of 4 total)