ppt_info22-05-20_122203766

map-location bug in Premium Press Directory Theme v9.4.3

I'm working with PremiumPress Directory Theme v9.4.3 , and I've noticed there's a small bug with the map-location field when editing listings. The project is a multi-author site, for the most part everything is working fine. I've granted certain authors access to wp-admin area, so they can edit listings directly, rather than using only the theme's front-end listing editor. Whenever an author access a listing using the wp-admin editor, for example to update the description or upload additional photos, the map-location field gets cleared when they update the listing with the update button, and the map-location field has to be updated again. The map marker isn't being cleared though. Please see the images below to help illustrate the issue:

Created: July 4, 2020 at 5:14 am
  • In: Bugs & Issues
  • Started by: info
  • 2 members left 7 comments
  • Last reply from: MarieMarie


  • info
    July 4, 2020 at 5:28 am

    Before Updating Listing:


  • info
    July 4, 2020 at 5:29 am

    Which button is used to update the listing:


  • info
    July 4, 2020 at 5:30 am

    Confirmation listing was updated:


  • info
    July 4, 2020 at 5:31 am

    map-location field empty after update:


  • info
    July 4, 2020 at 5:37 am

    It’s only a small issue, however, I can see it becoming quite tedious when every time an author wants to update the listing using the wp-admin listing editor, they will need to re-enter the map-location. Like I mentioned, the map marker remains intact, as the pictures show above, the map-lat and map-log fields don’t get cleared. But if an author forgets to re-enter the map-location, then the address line disappears from the listing, and the google map call out is then blank for that listing. It also stops the Directions feature from working, as when Directions is clicked, the resultant google map which opens in a new tab is blanked as well.

  • Marie
    Marie
    July 6, 2020 at 4:35 am

    hi,

    have you tried version 10 Directory Theme? Most of the fields in version 10 has been updated.


Viewing 7 posts - 1 through 7 (of 7 total)