Help, weird Warning messages on homepage

  • Sunny
    Sunny
    Newbie 48 points
    February 14, 2014 at 10:42 am

    I have the latest v 7.1.4 version of Agency Press installed on my website at https://findthaifriends.com

    It was working fine previously and I left it alone for a few months and I went to look at it today and now, it is displaying a long column of Warning messages such as:

    Warning: Illegal string offset ‘joiner’ in /home/findthai/public_html/wp-content/themes/agencypress/PPT/class/class_search.php on line 1404

    Can someone help me troubleshoot what is causing this?

    Thanks in advance for any help rendered.

  • Mark Fail
    Mark Fail
    Super Guru 13,013 points
    February 14, 2014 at 12:07 pm

    Check your advanced search options in the admin under your general setup tab, looks like some of your custom fields are invalid.

  • Sunny
    Sunny
    Newbie 48 points
    February 26, 2014 at 11:59 am

    Thank you Mark.

    By the way, when is the responsive theme for Agency Press coming out? 🙂

  • Mark Fail
    Mark Fail
    Super Guru 13,013 points
    February 26, 2014 at 1:09 pm

    AgencyPress is replaced with the new dating one.

  • Sunny
    Sunny
    Newbie 48 points
    February 26, 2014 at 7:19 pm

    Which new dating one? What’s it called and when will it be released?
    I looked through the list in the Members Area and could not see any dating theme.

  • Sunny
    Sunny
    Newbie 48 points
    May 22, 2014 at 2:37 pm

    Hi Mark

    I wiped clean my site and started with a brand new install of Agency Press. When I clicked on the reset the site to factory settings for a new install, I got the same error messages on my homepage are reported before:

    “Warning: Illegal string offset ‘joiner’ in /home/xxxxxx/public_html/wp-content/themes/agencypress/PPT/class/class_search.php on line 1421”

    I have not set up any custom fields yet.

    Any suggestions how to resolve this?

  • Sunny
    Sunny
    Newbie 48 points
    May 28, 2014 at 3:56 am

    Hi Mark

    I’m having the same problem as previously, but the difference is this time I’ve set up the site on a brand new installation without setting any custom fields. Its a stock installation and yet I am still getting these error messages on my homepage.

    Can you help me resolve this please?

  • Sunny
    Sunny
    Newbie 48 points
    May 31, 2014 at 4:11 am

    Hmmm… been a bit quiet around my side of the neighbourhood here…
    Anybody care to comment or help here?

  • Mark Fail
    Mark Fail
    Super Guru 13,013 points
    May 31, 2014 at 1:20 pm

    the error is due to your advanced search. try removing the widget or adjusting your advanved search options and see if this helps.

  • Sunny
    Sunny
    Newbie 48 points
    June 4, 2014 at 4:57 pm

    Mark, thank you for your reply.

    I deleted the fields in the search options and the error lines disappeared.

    I am just wondering why this is happening, as it was a brand new, clean, stock installation of the theme? I also set it to return to the default state.

    When I added a new field, a corresponding error line appeared on the homepage.

    What can be done to resolve this?

Viewing 10 posts - 1 through 10 (of 10 total)

New Business Themes for WordPress 2020

Start your new website today!

View Business Themes