LIMITED OFFER: Save $200 Today! - Get All Themes For $199 -- Learn More

Ask the community

This is a community support forum where you can ask
questions and interact with other PremiumPress Customers.

Amazon import plugin issue


  • Gary
    Newbie 2 points
    November 16, 2015 at 2:37 pm

    I am getting the same error.

    I have made certain that I am entering the keys without any extra spaces and they are correct. They are also listed as ‘active’ on Amazon.

    Please help.

    Thank you


  • Gary
    Newbie 2 points
    November 16, 2015 at 6:49 pm

    Oops! Turns out I was using the keys in the wrong order. Everyone be sure to use the right key in each field. They are presented from Amazon in the opposite order.

    Sorry for the mistake on my part!

  • Mark
    Mark
    Newbie 28 points
    March 17, 2016 at 2:06 pm

    Did anyone solve this I am trying to get he import plugin working in 8.9 but it just keep saying the keys are invalid.

    even though I know they are not and they work fine as I have used them with the S2 service in a different plugin.

    these are my keys that don’t work.
    AWSAccessKeyId=AKIAJVLUB2X6GHIW2KCQ
    AWSSecretKey=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

    I have also tried them the other way around as suggested in this post.

    here is the status of said key from amazon too prove they exist.
    Created
    Feb 3rd 2016 AKIAJVLUB2X6GHIW2KCQ 2016-03-17 13:43 UTC N/A ecs Active

    as you can see from the access date of 17th March is when it was used last which is the plugin hitting it. but the plugin still gets refused access.

    any ideas


  • Aaron
    Newbie 9 points
    February 7, 2018 at 9:32 pm

    The theme and accompanying video are wrong. You do not need AWS, the access/security keys are located under Amazon Associates.

    To obtain these, log into Amazon Associates…

    Click on the ‘Tools’ drop-down
    Click on ‘Product Advertising API’

    This should allow you to set up your credentials. Found this on the following website on step #9: https://www.wp-amazon-plugin.com/register-amazon-affiliate-product-advertising-api/


  • Francisco
    Newbie 2 points
    February 12, 2018 at 9:20 am

    Same problem over here. I used the keys of both, aws and amazon affiliates and still giving the same error. Is something known already?


  • José Carlos
    Newbie 1 points
    December 21, 2018 at 8:57 pm

    I have the same problem, does anyone know why after putting the credentials right I get this problem?
    Amazon API Details Invalid
    We could not connect to Amazon because your Amazon import settings are incorrect.

Viewing 6 posts - 16 through 21 (of 21 total)