Users unable to see and edit their own listing page

WordPress Business Themes Forums Responsive Themes Directory Theme Users unable to see and edit their own listing page

Discontinued - The forum content is out of date. For theme support please use our support desk here.

Users unable to see and edit their own listing page

April 5, 2019
 George

  • George
    Newbie 27 points

    I am having a problem where users are unable to access their own listings. They get either a white screen or a message they are not allowed access to this page.

    Admin can see and edit listing.
    Other logged in users can see the listing.
    Visitors can see the listing

    The site is:

    Home

    Any tips are welcome. The problem started after upgrading to php 7.2 and appears to be a theme incompatibility. I am not ready to upgrade to V9. I am hoping there is a fix for V8 that can be applied.

    April 5, 2019 at 12:31 am

  • George
    Newbie 27 points

    To clarify: This happens only after the upgrade with NEWLY added listings. The existing users continue to be able to access their own listing pages.

    April 5, 2019 at 12:48 am
  • Marie
    Marie
    Super Guru 1,747 points

    hi george

    did you assigned Page access to your listings?

    Also check your permalinks make sure its using the Postname

    April 5, 2019 at 2:21 am

  • George
    Newbie 27 points

    Hello Marie,

    Thanks for responding.
    Where is the setting for assigning Page access to your listings?

    Permalinks are set to Postname.

    Thanks,

    Boel

    April 5, 2019 at 8:34 pm
  • JamesD
    JamesD
    Super Guru 1,351 points

    Hi George,
    There’s a default setting at PremiumPress > Memberships > PAGE ACCESS > DEFAULT LISTING PAGE ACCESS and look near the bottom right corner on the page & listings edit pages and you’ll see a Page Access setting like in the image.

    Attachments:
    You must be logged in to view attached files.
    April 6, 2019 at 3:32 am

  • George
    Newbie 27 points

    OK, thanks much James. That was already correctly set. I think, though I can’t find the exact path you are showing here. The one I see looks like this:

    April 8, 2019 at 2:22 am

  • George
    Newbie 27 points

    Sorry James, attachment did not go through. The one I see is on the Listing Setup page. Looks like this:

    Attachments:
    You must be logged in to view attached files.
    April 8, 2019 at 2:30 am
  • JamesD
    JamesD
    Super Guru 1,351 points

    @George

    That was already correctly set. I think, though I can’t find the exact path you are showing here.

    Gotcha, was thinking version 9, not 8.

    Is the Theme Setup > Listing Setup > Settings > Listing Status setting set to Active (Live)?

    Attachments:
    You must be logged in to view attached files.
    April 8, 2019 at 3:30 am

  • George
    Newbie 27 points

    It is not, because I don’t want them to go live without payment…

    April 8, 2019 at 3:44 am

  • George
    Newbie 27 points

    That said, I changed to Active (live) just to see, and the problem remains.

    April 8, 2019 at 4:12 am
  • JamesD
    JamesD
    Super Guru 1,351 points

    It is not, because I don’t want them to go live without payment…

    It could be a MySQL error. Honestly, the fastest way to determine where to start looking for the problem is by your error log or possibly using WP_DEBUG.

    I’m curious, is the error/message viewed immediately after creating, or does it still do it if they navigate to another page then navigate back to he listing page?

    April 8, 2019 at 4:17 am
  • Marie
    Marie
    Super Guru 1,747 points

    hi George

    did you checked your Listing Manager, if the listings were published and not in draft?

    because changing the setting to Live from Theme Setup > Listing Setup > Settings > Listing Status will only affected newly created listings but not those listings submitted before you made the changes to the setting.

    Make sure the listing were published

    April 8, 2019 at 8:00 am

  • George
    Newbie 27 points

    James: “I’m curious, is the error/message viewed immediately after creating, or does it still do it if they navigate to another page then navigate back to he listing page?” It happens if they navigate away and come back. The user gets a white screen regardless.

    Marie: Yes, the listing is in published status, and can be seen by other users (previously registered).

    April 13, 2019 at 11:24 pm
  • JamesD
    JamesD
    Super Guru 1,351 points

    @George

    James: “I’m curious, is the error/message viewed immediately after creating, or does it still do it if they navigate to another page then navigate back to he listing page?”

    I’ve only experienced immediately after.
    Note: Remember, the information in error log(s) can be insightful, especially in situations like you’re experiencing. 😉

    April 13, 2019 at 11:31 pm

  • George
    Newbie 27 points

    I don’t think I have the tech chops to interpret the error log though.

    April 13, 2019 at 11:33 pm
Viewing 15 posts - 1 through 15 (of 26 total)

Didn't find what you were after?

Chat with us now

or contact our support team