Todd

Need clear description of how to use [FIELDS] shortcode

I have about 10 custom fields that I collect for each listing. However, I only want to display 4 of these fields. I cannot for the life of me figure out how the FIELDS shortcode actually works. Assume I have the following 6 fields and want to hide B,C,distance, and address. (they are all custom except for distance and address.) A B C D distance address I tried [FIELDS hide="distance, etc...... not getting the result I want. Is there a good example of how to use this shortcode somewhere? Thanks

Created: July 28, 2016 at 11:38 pm
  • In: Directory Theme
  • Started by: Todd
  • 6 members left 22 comments
  • Last reply from: Josh


  • Todd
    July 29, 2016 at 4:23 am

    I think I’ve figured out how the [FIELDS] shortcode works. So here is a description for anyone else who is trying to understand it.

    The syntax is [FIELDS show=”” hide=””]
    In order to display some but not all of my fields I had to do the following:

    Assuming these are my custom fields: one,two,three,four,five and I want to display one,three and four only.

    I used [FIELDS show=”default” hide=”two|five”]

    If I didn’t include “default”, I couldn’t get anything to show.

    Not sure if this is the intended behavior, but it worked for me.


  • Josh
    July 29, 2016 at 2:54 pm

    Thanks for sharing Todd 🙂

  • Jason
    Jason
    August 3, 2016 at 10:11 pm

    Good to see.

    May I ask for a little help maybe.

    How do I hide the KEYWORDS from showing within viewing a listing.

    Pic attached

    Attachments:
    You must be logged in to view attached files.
  • Alex Morgan
    Alex Morgan
    August 4, 2016 at 9:42 am

    Hi Jason,

    Please try to use this [FIELDS hide=”tags”]

  • Jason
    Jason
    August 4, 2016 at 10:12 am

    Where am i putting this code exacly, is there a screen snap someone could show me pls ?

  • Alex Morgan
    Alex Morgan
    August 4, 2016 at 10:18 am

    Hi Jason,

    1. Please go to Theme setup > Page setup > Listing page tab >
    2. please turn ON the Custom Display switch
    3. Please click on Load Default Layout button
    4. You can now add/replace the shortcode.

  • Jason
    Jason
    August 4, 2016 at 11:12 pm

    Doesnt work, Pic attached

    Attachments:
    You must be logged in to view attached files.
  • Jason
    Jason
    August 5, 2016 at 12:28 am

    This is what works for me in pic, anywhoooo, cheers guys

    Theme Setup, Custom CSS

    #TableCustomFieldsBig tr:last-child {
    display:none;
    }

    Attachments:
    You must be logged in to view attached files.

  • Josh
    August 5, 2016 at 2:11 pm

    Thanks for sharing Jason 🙂


  • MARIA ANGELES
    August 30, 2016 at 4:25 pm

    Hello,
    I am trying the sintax [FIELDS hide=”map-state”], to not show the State in the Details tab, but not working. I try [FIELDS hide=”phone”], it works.
    Any idea?

    Another question, which can be the syntax for taxonomies? Because [FIELDS] includes showing taxonomies. I’ve tried with taxonomy name and doesn’t work.
    Thanks in advance


  • Josh
    August 30, 2016 at 6:09 pm

    Hello Maria,
    try the below code under Theme Setup >General Setup >Custom CSS >Footer Styles
    taxonomies are you referring to please

    Attachments:
    You must be logged in to view attached files.

  • MARIA ANGELES
    August 30, 2016 at 7:42 pm

    Hello,
    seems not working, I put the code where you said (take a look to ), test link:

    in “Details”. We want not to show “Comunidad”, because we have taxonomy “Comunidad Autónoma” and because it doesn’t work properly with some States (for example, “Euskadi” instead of “Pais Vasco”)
    In the , “Comunidad Autónoma”, “Provincia” and “Naturaleza”, are taxonomies, is there any syntax we can use to selectively hide it?
    Thanks in advance.

    Attachments:
    You must be logged in to view attached files.

  • Josh
    August 31, 2016 at 1:01 pm

    Hello Maria,
    In my code replace State/Province with the name of the section you want to hide eg Provincia So replace my text with the name of your state field
    More info >>

    Did you create the taxonomy using the Taxonomy plugin?If so you cannot display the taxonomy in the Details display a taxonomy created using the plugin please use the shortcode
    [CTAX key=XXXX]
    Replace XXXXX with the key you’ve assigned opposite for your taxonomy


  • MARIA ANGELES
    August 31, 2016 at 2:19 pm

    It works well!!!
    Thanks a lot.
    Regards


Viewing 15 posts - 1 through 15 (of 23 total)