WordPress Business Themes › Forums › General Discussion › Minimum requirements for using a PP Theme
Hi Mark what are the minimum requirements for running your themes and plugins?
Your site states… as of today.
PHP 5.2.4 or greater
MySQL 5.0 or greater
The mod_rewrite Apache module
Additional theme requirements;
PHP sessions (enabled)
PHP file_get_content (enabled)
PHP cURL (enabled)
Maybe you need to update this because I have clients running your themes that are being told that they need to update to PHP 5.5 for a simple plugin to work. What’s up? Care to elaborate.
I run a lot of sites using your themes. And all very happy. On dedicateds and to just upgrade a distro because of a plugin is a bit of a pain and expensive for the client. PHP will not run happily along side other versions because the binaries are stored in the same location, it can be done maybe but I don’t like to take servers off stable, in fact I won’t. So for a simple plugin I need to upgrade a distro?
Just want to add our experience to David’s comment, we are converting a non responsive shopperpress site to the responsive version, we are using version responsive shop theme 6.6.0 on WP 3.91 with Marks IMPORT CSV import/export plugin version 3.0.
The problem we are having is that we get an error when we try to import, have contacted the support desk and Zarko asked us to check that the allow LOAD function is enabled, and that has been confirmed by our Hosting provider and Alex has also stated that we must upgrade to PHP version 5.5, we are currently running PHP Version 5.3.10.
This is going to cause us huge problems for the reason that David has highlighted above and also because we run many sites on the same server and it’s going to be a big job to determine what effect upgrading php will have on the other co-located sites, if indeed we can get a php upgrade done at all.
Mark, can you rework the plugin so that it will run with a lower version of PHP please as I am sure this is also going to impact a lot of other users as well once they upgrade the plugin and theme to the latest version and try to use the import plugin.
The errors are attached
@David, You don’t need CSV plugins to run the themes. Minimum theme requirements therefore are as stated and valid.
If you want to use additional plugins and/or additional features then they each will have their own requirments.
@Dave, you don’t need PHP 5.3.10 to run the CSV tool, the error your getting is because your hosting has disabled your LOAD IN functionality for your PHPMYAdmin. You’ll need to speak to your hosting to enable it. Regardless of hosting providers tells you its there (they do this all the time) if your getting the error from PHP then its because its cannot find the resource and thus its not correctly enabled.
Seems to be sorted with a modified version of the plugin.
I was just wondering why your official plugins need a different PHP version to work with the theme??
It’s not the case anyway apparently.
Must be extremely difficult keeping up with things in this ever changing, fast paced internet world. 😎
aye it is
I know Mark from first hand experience, but keep at it!
Submit your feature requests to our ideas board and it could be included in a future theme update.
or contact our support team