LIMITED OFFER: Save $200 Today! - Get All Themes For $199 -- Learn More

Ask the community

This is a community support forum where you can ask
questions and interact with other PremiumPress Customers.

making social media icons in listing work

  • Douglas
    Douglas
    Senior Member 102 points
    April 19, 2016 at 6:17 am

    Hi all,
    Every listing I create has social media icons on top right of screen. I can’t find how to have them go to the listing’s facebook or twitter page. Cant even make my own SM icons go to my facebook pages!

    All help gratefully received.


  • Josh
    Super Guru 13,885 points
    April 19, 2016 at 2:49 pm

    Hello Douglas,
    The Listing social media icons are sharing icons.You can use custom fields if you want users to add social media links to their listings.To add social media links to profile please go to Theme Setup >User Setup >User Account >My Details Tab and turn on ‘Show Social Media Options’

  • Jason
    Jason
    Guru 837 points
    April 19, 2016 at 10:07 pm

    Howdy Guys.

    Question

    How do i remove all the other social icons and only have the Facebook, and link it to the Facebook page ?

  • Douglas
    Douglas
    Senior Member 102 points
    April 19, 2016 at 10:29 pm

    @josh,
    Thanks for your help Josh.
    I haven’t paid much attention to the social icons provided with the theme up to now. When I take a good look at them I can see what you said and why they don’t show up in the listings menu. I guess when one person is responsible for design and implementation of a theme, somethings might seem trivial and get left out. On the whole though this is a better than average theme considering it uses a CMS for its base functionality.

    I think I’ll kill the idea of social icons altogether and work on using hyperlinks to a specific facebook page (the most popular destination) with a facebook icon in the listing itself. It might not look as impressive but anything that doesn’t function is superfluous anyway — In my opinion.

  • Douglas
    Douglas
    Senior Member 102 points
    April 19, 2016 at 10:41 pm

    @josh
    Turning off social Icons using your described method does not in reality turn off those icons. They stay in the listings. Does your instruction only prevent them from appearing in new listings, leaving existing ones showing the icons?

  • Jason
    Jason
    Guru 837 points
    April 19, 2016 at 10:48 pm

    In this pic I guess

    In the footer

    Attachments:
    You must be logged in to view attached files.

  • Josh
    Super Guru 13,885 points
    April 20, 2016 at 3:25 pm

    Hello Douglas,
    To remove the listing social media links please try the below code under Theme Setup >Custom css

    .core_middle_wrap .pull-right {
    display:none;
    }

  • Douglas
    Douglas
    Senior Member 102 points
    April 20, 2016 at 11:54 pm

    Hey Josh…
    That code is akin to using a sledge hammer to drive a small nail into a chair… It broke the chair!

    Took out an essential piece of the listing — The ‘claim listing’ button!

    Seriously Josh… The dram I’m having doesn’t look like ending anytime soon. Fix one bug and another pops up. I’ve got an unresolved ticket about this. I sent Mark Fail a screen shot to demonstrate the stupidity of having social icons in a listing that do nothing unless some other provider gets their monthly fee.

    I’ve still got 10 licenses left for a Belorussian PHP directory that doesn’t have any of these issues. I might yet pay the cost of having staff re-enter listings just to get a trouble free directory. Premium Press Directory has consumed nearly $3000 of wages so far and still not doing what I expected (based on other Directories performance).

  • Dwayne
    Dwayne
    Senior Member 142 points
    April 21, 2016 at 3:26 am

    Hi Douglas,

    To remove the social icons from your listings:

    1. Go to Theme Setup > Page Setup > Listing Page
    2. Scroll down and turn on “Enable Custom Display” (this is where you can design the layout of your listing page)
    3. Select “Get Codes from Default Layout” (don’t do this if you have already designed your listing page using the Enable Custom Display box as it will replace your layout with the PP Default Layout)
    4. Delete [D_SOCIAL] (this is the shortcode that displays the social icons on your listing page)
    5. SAVE CHANGES using the button at the bottom of the page

    Hope this is what you’re after :)

    This reply was awarded the best answer by the topic poster.
  • Dwayne
    Dwayne
    Senior Member 142 points
    April 21, 2016 at 3:35 am

    Hi Jason,

    1. Go to Theme Setup > General Setup > Footer
    2. Scroll down to Social Buttons
    3. Delete ## from the icons you don’t want listed
    4. Replace the Facebook ## with your Facebook link
    5. Save Changes

    Hope this helps.

  • Jason
    Jason
    Guru 837 points
    April 21, 2016 at 5:35 am

    Thanks Guys.

    I cant find a post anywhere that relates to this question, in picture attached how to ?

    Attachments:
    You must be logged in to view attached files.
  • Jason
    Jason
    Guru 837 points
    April 21, 2016 at 8:20 pm

    PLEASE anyone know how to make this text in BOLD

    HELP !

    Pic attached

    Attachments:
    You must be logged in to view attached files.
  • Douglas
    Douglas
    Senior Member 102 points
    April 21, 2016 at 9:47 pm

    @Dwayne,
    Thanks for that. Got rid of the icons and left everything else intact.

  • Denise
    Denise
    Newbie 43 points
    November 26, 2019 at 9:25 pm

    Social media icons are no longer available?

  • Jason
    Jason
    Guru 837 points
    November 27, 2019 at 2:05 am

    Wow last time I had anything to do with this thread was 2016, need to unsubscribe if people above are still commenting on old stuff that has nothing to do with version9

Viewing 15 posts - 1 through 15 (of 16 total)