Chuck

How to enable reviews under "Reviews" tab – now empty

In my comparison script installation, every listings (aka product) page has a tab for "Reviews" but when you click on it, there's nothing under the tab - no form for users to submit reviews. Where/How do I turn this on? Been looking for over 2 hours and no forum threads addressing this issue as far as I can see.

Created: January 8, 2017 at 12:36 am
  • In: Comparison Theme
  • Started by: ChuckChuck
  • 2 members left 14 comments
  • Last reply from: Josh

  • Chuck
    Chuck
    January 8, 2017 at 1:39 am

    I went to Theme Settings>>Page Setup>>Listing Page
    and enabled custom display then clicked “Get Codes from Default Layout” to see what’s going on in the code, and sure enough, the [COMMENTS] shortcode is in the code so this is confusing. Also, yes comments are enabled in wordpress settings.

    Also worth noting that if I place a comment under a listing within the admin of WP, the comment does show up on the listings page, however there is still no form for the visitor to submit a comment/review.

    Here’s the code from “Get Codes from Default Layout”:

    <div class="panel panel-default">

    <div class="panel-body">

    <h1>[TITLE-NOLINK]</h1>

    <div class="pull-right" style="margin-top:-10px;">[D_SOCIAL]</div>

    <div class="details">

    [RATING small=1 rating=1 style=1] / [hits] views / [CATEGORY]

    </div>

    <hr />

    <div class="row">
    <div class="col-md-6">

    [IMAGE gallery=1]

    </div>

    <div class="col-md-6">

    [CONTENT size=500 extra=0]

    </div>
    </div>

    <div class="clearfix"></div>

    <hr />

    <div class="tabstyle1">

    <ul class="nav nav-tabs " role="tablist">

    <li class="active">Compare Prices

    Details

    Reviews

    <li class="pull-right hidden-xs favs">[FAVS]

    </div>

    <div class="tab-content">

    <div role="tabpanel" class="tab-pane active" id="t1">

    [COMPARISONTABLE]

    </div>

    <div role="tabpanel" class="tab-pane" id="t2">

    [FIELDS]

    </div>

    <div role="tabpanel" class="tab-pane" id="t3">

    [COMMENTS]

    </div>

    </div>

    <h3 class="related"></h3>

    <hr />

    [RELATED perrow=3]

    </div>

    </div>

  • Chuck
    Chuck
    January 8, 2017 at 1:47 am

    Sorry, I tried posting the code with and without “code” tags to no avail. Some code ends up missing on the forum post.

  • Chuck
    Chuck
    January 9, 2017 at 4:10 am

    I “resolved” this issue by downloading a plugin called Reviews Plus by Implecode, which turns your comment forms into review forms.

    There are a couple little quirks with it though…

    1. It directs users to a blank page after submitting the review.
    2. It automatically posts reviews on the site without notifying me, even though I have the plugin and WP set to notify me of new submissions and to hold them for review.

    I put in a support request to the plugin author to see if he can resolve it.

    I didn’t want to go this route and I’m not sure how using this plugin magically makes the form show up under the reviews tab, but it’ll do for now.

    If anyone can tell me why the comments form does not show up without the use of an outside plugin, I’m all ears.


  • Josh
    January 9, 2017 at 1:04 pm

    Hello Chuck,
    Please go to Theme Setup >Content Setup >Star Rating & Feedback System >Feedback

  • Chuck
    Chuck
    January 9, 2017 at 7:25 pm

    Hey,, Josh.

    I already tried enabling feedback and it did not work.

    But that isn’t the right setting anyway because that’s for enabling members to give other members feedback, not for listing feedback/comments/rating. It says in that section…

    “The feedback system allows members to leave feedback about other members listings. Members can leave 1 feedback per listing and the listing author can delete the feedback at any time. Feedback is displayed on the users profile #8221;

    I don’t need/want this feature anyway lol.

    I have disabled the ratings plugin I spoke of in my last post so that you can see the problem.

    Pic 1: Showing Feedback setting turned on.
    Pic 2: Showing comments are turned on for the product in WP listings back end.
    Pic 3: Showing no comment form on listing page.

    Attachments:
    You must be logged in to view attached files.
  • Chuck
    Chuck
    January 9, 2017 at 7:26 pm

    sorry, above post would not accept more than one photo…

    Attachments:
    You must be logged in to view attached files.
  • Chuck
    Chuck
    January 9, 2017 at 10:17 pm

    test


  • Josh
    January 10, 2017 at 1:43 pm

    Hello Chuck,
    Send me your login details so I can check this for you >>joshnjengak@

  • Chuck
    Chuck
    January 10, 2017 at 2:03 pm

    Thanks, Josh. Just sent details now.


  • Josh
    January 10, 2017 at 3:24 pm

    Please check now

  • Chuck
    Chuck
    January 10, 2017 at 4:23 pm

    Yup, it worked Josh! Thank you.

    However, thing is, that’s a test site and I’m going to need to know what you did so that I can fix it on my live sites. Can you please let me know what you did to resolve this issue when you get a chance?


  • Josh
    January 10, 2017 at 4:27 pm

    Thanks for updating Chuck.
    I added a custom code for you under Theme Setup >General Setup >Custom css

  • Chuck
    Chuck
    January 10, 2017 at 4:38 pm

    Opps, didn’t think to look there. Thanks a bunch!

    For anyone interested, the 2 lines of code Josh inserted are…

    #wlt_comments_form {display:block !important;}
    #wlt_comments_form .badge {display:none;}


  • Josh
    January 10, 2017 at 7:37 pm

    Thanks for sharing a great day 🙂


Viewing 15 posts - 1 through 15 (of 15 total)