How to Change Coupon/Discount Code Image

WordPress Business Themes Forums Version 7 Themes ShopperPress How to Change Coupon/Discount Code Image

How to Change Coupon/Discount Code Image

July 19, 2013
Brandon Brandon
  • Brandon
    Brandon
    Titan 709 points

    I would like to change the Coupon/Discount Code image.

    I do not like the 2 green arrows. I think there should be a button to replace the 2 arrows that says APPLY.

    Anyone have any idea how to do this.

    July 19, 2013 at 5:50 am
  • Brandon
    Brandon
    Titan 709 points

    here is picture

    Attachments:
    You must be logged in to view attached files.
    July 19, 2013 at 5:50 am
  • Ian
    Ian
    Super Guru 1,200 points

    That shouldn’t be hard to change. I’ll be out for a few hours but will look when I get back.

    July 19, 2013 at 6:11 am
  • Brandon
    Brandon
    Titan 709 points

    thanks Ian

    July 19, 2013 at 6:23 am
  • Mark Fail
    Mark Fail
    Super Guru 12,812 points

    thanks for sharing

    July 19, 2013 at 7:57 am
  • Ian
    Ian
    Super Guru 1,200 points

    Copy template_shopperpress/_tpl_checkout.php to your child theme folder, then in that file find

    <form name="ccode" method="POST" class="checkoutcouponbox">         
            
            <?php wp_nonce_field('ShopperPressCoupon') ?> 
            <b><?php echo $PPT->_e(array('sp','15')); ?></b><br />
                <input name="ccode" type="text" class="checkoutcouponinput"> 
                <a href="#" onclick="document.ccode.submit();">
                    <img src="<?php echo get_bloginfo("template_url")."/template_shopperpress/images/refresh.png"; ?>" align="middle" />
                </a>
            </form>	

    and change to

    <form name="ccode" method="POST" class="checkoutcouponbox">         
            
            <?php wp_nonce_field('ShopperPressCoupon') ?> 
            <b><?php echo $PPT->_e(array('sp','15')); ?></b><br />
                <input name="ccode" type="text" class="checkoutcouponinput"> 
                <a href="#" onclick="document.ccode.submit();">
                    <input class="button gray" tabindex="5" value="Apply" style="width:50px"> 
                </a>
            </form>	
    July 19, 2013 at 8:55 am
  • Brandon
    Brandon
    Titan 709 points

    it is Not working for me.

    Parse error: syntax error, unexpected T_ELSEIF in /home/cobramot/public_html/wp-content/themes/shopperpress/themes/shopperpress-Classic-Shop/_tpl_checkout.php on line 1

    I have attached file that I inserted your code into.

    Attachments:
    You must be logged in to view attached files.
    July 19, 2013 at 3:04 pm
  • Brandon
    Brandon
    Titan 709 points

    and just to confirm I made a copy of the file and inserted your code then I put the file into my Child Theme Folder.

    July 19, 2013 at 3:05 pm
  • Ian
    Ian
    Super Guru 1,200 points

    Your file works fine for me, try again. If it errors refresh a couple of times to see if it outputs the same error every time.

    July 19, 2013 at 9:47 pm
  • Ian
    Ian
    Super Guru 1,200 points

    Using your file in classic shop

    Attachments:
    You must be logged in to view attached files.
    July 19, 2013 at 11:05 pm
  • Brandon
    Brandon
    Titan 709 points

    Ian, it is still not working for me.

    Can you add the code to my attached file and then attach it to this post.

    I will download yours and add it.

    July 19, 2013 at 11:50 pm
  • Brandon
    Brandon
    Titan 709 points

    here is what I am getting.

    Parse error: syntax error, unexpected T_ELSEIF in /home/cobramot/public_html/wp-content/themes/shopperpress/themes/shopperpress-Classic-Shop/_tpl_checkout.php on line 1

    July 19, 2013 at 11:52 pm
  • Brandon
    Brandon
    Titan 709 points

    Weird, for some reason when I copy codes into my editor programs the files will not work.

    But if I type it all in the codes work.

    I use CoffeeCup Free HTML Editor and Notepad + +

    July 20, 2013 at 12:11 am
  • Brandon
    Brandon
    Titan 709 points

    Code works.

    Thanks Ian

    July 20, 2013 at 12:12 am
  • Brandon
    Brandon
    Titan 709 points

    Ian, I just found small Issue.

    The APPLY Button is a different size in each Browser (Chrome, FireFox and IE)

    see Pics and let me know how I can fix this.

    July 20, 2013 at 1:20 am
Viewing 15 posts - 1 through 15 (of 25 total)

Didn't find what you were after?

Chat with us now

or contact our support team