CSS changes not working?

  • Janet
    Janet
    August 14, 2015 at 12:38 pm

    I am using the Directory theme with Restaurant child theme.
    When I try to make changes to the CSS in the child theme’s style sheet, nothing changes.
    I keep saving the changes and refreshing the browser, but still nothing.
    What am I doing wrong?


  • Josh
    August 14, 2015 at 12:41 pm

    Hello Janet,
    What changes are you trying to make?Also try to clear your browser cache

  • Janet
    Janet
    August 14, 2015 at 12:45 pm

    Hi Josh,
    I tried clearing the cache as well – still no changes.
    The changes that I was trying to make were to the colours of the main menu.

    I inserted this into the style.css for the child theme, but nothing changed:

    /*** DROPDOWN MENU ***/
    #core_menu_wrapper .navbar-nav > li a:hover {
    background-color: #23282d;
    }

    #core_menu_wrapper .dropdown-menu { /*** Dropdown Menu Background Color ***/
    background-color: #23282d !important;
    font-color: #fff;
    font-size:14px !important;
    }

    #core_menu_wrapper .dropdown-menu > li > a { /*** Dropdown Menu Font Color ***/
    color: #ffffff !important;
    text-shadow: none !important;
    }

    #core_menu_wrapper .dropdown-menu > li > a:hover {
    color: #ffffff !important; /*** Dropdown Menu Font Rollover Color ***/
    background-color: #23282d !important; /*** Dropdown Menu Hover Box Color ***/
    }


  • Josh
    August 14, 2015 at 1:13 pm

    Try this in Design Setup >Custom Meta Data >Header Styles
    <style>
    #core_menu_wrapper .navbar-nav > li a:hover {
    background-color: #23282d !important;
    }
    #core_menu_wrapper .dropdown-menu {
    background-color: #23282d !important;
    font-color: #fff;
    font-size:14px !important;
    }
    #core_menu_wrapper .dropdown-menu > li > a {
    color: #ffffff !important;
    text-shadow: none !important;
    }
    #core_menu_wrapper .dropdown-menu > li > a:hover {
    color: #ffffff !important;
    background-color: #23282d !important;
    }
    </style>

  • Janet
    Janet
    August 14, 2015 at 1:17 pm

    Hi Josh,
    I made the changes as you suggested – and then cleared the cache, refreshed, etc – still no changes.
    I’ve also tried viewing on different browsers, but still nothing.
    Is there a difference between style.css and the Meta Data place?


  • Josh
    August 14, 2015 at 1:36 pm

    The Header Styles section adds the code between the <HEAD>tags.In both cases (child theme style.css and Header Styles section ) changes will not be lost in new update.
    The code is working on my Theme.What happens when you disable the child Theme?

  • Adnan
    Adnan
    August 14, 2015 at 1:43 pm

    Can you post your site link?

  • Aaron
    Aaron
    August 14, 2015 at 1:43 pm

    Adding !important to those css styles is pointless. Maybe if the user has already tried this and has failed this may solve their problem but this approach is going to be a pain in the long run.

    Janet, it looks like you are using a child theme – is this correct?

  • Janet
    Janet
    August 14, 2015 at 1:54 pm

    Hello Aaron and Josh.
    I deactivated the child theme (restaurant child theme) – by activating the normal directory theme (not sure if that is the right way to do it) – Still no changes.
    I also tried previously having all the CSS without the !important (because I was taught to use that sparingly), but when that didn’t work, I tried adding it – it didn’t seem to make any difference.
    The url is: http://www.biotechdirectory.com.au
    One interesting thing that I found – using Firefox and Firebug, I change the colours on the firebug listing of all the styles and that worked. This told me I was trying to change the right thing, but when I tried changing the same css in the actual style. css file, nothing happens.

    There seems to be something blocking all my css changes – I just don’t know what.

  • Aaron
    Aaron
    August 14, 2015 at 2:10 pm

    The hover colour is dictated by:

    .dropdown-menu > li > a:focus, .dropdown-menu > li > a:hover {
    background-color: #555;
    color: #262626;
    text-decoration: none;
    }

    Change 555 to suite.

    The problem with those inline styles is the fact you have 11 of the same style all overriding each other every time you make a change – this is asking for trouble.

  • Janet
    Janet
    August 14, 2015 at 2:25 pm

    Hi Aaron,
    Thanks for your suggestion. I took the css out of the Custom Meta Data place and put the css you suggested in the style.css file for the child theme – still no change after saving, refreshing and clearing the cache.


  • Josh
    August 14, 2015 at 2:33 pm

    Are you using any cache plugin?

  • Janet
    Janet
    August 14, 2015 at 2:36 pm

    Hi Josh,
    There is one plugin called SG CachePress, but I deactivated it because I thought that might have been the problem. Deactivating it didn’t make any difference either. I’ve left it deactivated because I wasn’t sure what it was doing and wanted to remove anything that might be the trouble.


  • Josh
    August 14, 2015 at 3:04 pm

    I think you should open a ticket

  • Janet
    Janet
    August 14, 2015 at 3:06 pm

    Hi Josh,
    yes, I think you’re right – many thanks for your help – very much appreciated!

Viewing 15 posts - 1 through 15 (of 20 total)

Copyright © 2010-2020 PremiumPress Limited.

secure payments