Ask the community

This is a community support forum where you can ask
questions and interact with other PremiumPress Customers.

bbpress side bar missing and elementor not working with bbpress page

  • Mick
    Mick
    Newbie 57 points
    May 17, 2019 at 11:39 pm

    Is anyone using bbpress with the current version of themes?
    After years of using bbpress successfully with Premiumpress themes, it now seems that something is not compatible.
    I no longer have the sidebar for the forums and when trying to edit the page with elementor, It will not work.

    Any idea how to rectify these problems?

    Attachments:
    You must be logged in to view attached files.
  • JamesD
    JamesD
    Super Guru 1,345 points
    May 18, 2019 at 12:26 am

    Hello Mick,
    Plugins need to be designed to use Elementor, so I don’t believe bbPress will automatically integrate with Elementor.

    Here’s a plugin that may help:
    https://www.csshero.org/plugins/elementor/

    Note: I know nothing about the plugin other than it suppose to make customizing bbPress forum easier and that it does require purchase.

  • Mick
    Mick
    Newbie 57 points
    May 18, 2019 at 9:57 pm

    Hi James,
    I can do without the elementor working on forum page.
    All I need is to enable a sidebar for the forums.

    Surely there is simple code Mark can share to do this.

  • JamesD
    JamesD
    Super Guru 1,345 points
    May 18, 2019 at 10:35 pm

    @Mick
    Have you tried assigning the [BLANK PAGE – SIDEBAR] template to the page? You can use the WP sidebar widgets with that template.

  • Mick
    Mick
    Newbie 57 points
    May 19, 2019 at 9:52 pm

    Hi James,
    I managed to use [BLANK PAGE – SIDEBAR] template however the sidebar is showing an add new listing button at the top of the sidebar but not allowing any other widget to show.
    It seems that the widgets are not being recognized.

  • JamesD
    JamesD
    Super Guru 1,345 points
    May 19, 2019 at 11:01 pm

    @Mick

    however the sidebar is showing an add new listing button at the top of the sidebar

    The button is in the header menu which is dependent upon the page template (and within a separate file). It has no impact with or without a sidebar.

    It seems that the widgets are not being recognized.

    Under Appearance > Widgets make sure that the widgets are placed in the proper sidebar column. There is one for Blog Sidebar (for blog pages) and one for Page Sidebar (for standard pages with sidebars).

    Looks like using the [PAGE – BLOG] page template and placing the WP widgets in the Blog Sidebar column would be about the extent of it without getting into Elementor or manual changes.

  • Mick
    Mick
    Newbie 57 points
    May 20, 2019 at 11:02 am

    Thanks James.
    You are wrong regarding the add new listing button. Somehow it is showing at the top of the blog sidebar. It is not on any other page other than the blog page.
    I might add that I am using the LocateMe child theme if that makes a difference. Maybe it is corrupting the files somehow.
    Any ideas how to get rid of the button?

  • JamesD
    JamesD
    Super Guru 1,345 points
    May 20, 2019 at 8:35 pm

    @Mick

    You are wrong regarding the add new listing button. Somehow it is showing at the top of the blog sidebar. It is not on any other page other than the blog page.

    You may want to contact PP support for proper assistance.

    Note: As I previously stated The button is in the header menu which is dependent upon the page template…. If you follow the process within the files you would see what I’m referring to.

Viewing 8 posts - 1 through 8 (of 8 total)