WordPress Hosting & Requirments

Hosting is the backbone of your business, get it right the first time…


Choosing the right hosting provider for your website can make a huge impact on your website performance, if the hosting provider offers poor service and performance your website and business might never get of the ground!

We have years of experience in working with hosting providers both for day to day maintenance and support therefore the list below is our recommended service providers.

NameDiscount CodeDiscountLink
HostUponWordPress1515% Off All PlansMore Details
hostupon

Green Geekspremiumpress$30 Off New HostingMore Details
green geeks


Theme Requirements


PremiumPress themes are built for WordPress (.org) version 3.1+ (and all versions above).
WordPress is one of the most popular blogging platforms online today and as such, most hosting providers are setup to support WordPress without any additional changes/add-ons.
We do recommend that you speak with your hosting provider to ensure they support WordPress and any additional requirments below;

WordPress hosting requirements;

  • PHP 5.2.4 or greater
  • MySQL 5.0 or greater
  • The mod_rewrite Apache module
  • Additional theme requirements;
  • PHP sessions (enabled)
  • PHP file_get_content (enabled)
  • PHP cURL (enabled)