Map settings not working in Directory themes


  • Usman
    Newbie
     
    2 points

    I am providing longitude and latitude settings but the map keeps pointing to pacific ocean. I want to load Australia by default.
    Also map zoom setting is not taking effect.
    The Map displays in all child themes except Maggilo theme.
    Does anyone know how to troubleshoot these issues? Premiumpress chat support never comes online.

    Thanks.


    JamesD
    JamesD
    Elite Member
     
    448 points

    Hello Usman,

    “I am providing longitude and latitude settings but the map keeps pointing to pacific ocean. I want to load Australia by default.
    Also map zoom setting is not taking effect.”

    There are a number of reasons this can happen.

    The default map view is based off of the locations of all the listings map coordinates. It calculates them then provides a “central” view of them all, so if you have listings with the locations scattered about the world then you can expect this to happen. (for example, if you’re still using the default listings that were installed with the theme-this would be the problem).

    If you change ALL of the listings map cords to be located in Australia then you should see the map being centered around Australia (because that’s where ALL of the markers will be). Make sense?

    You can check by zooming out (mouse scroll if buttons don’t work) and check if all the markers are scattered about the world. If so, then you need to make sure the listings have the proper map marker location set within each listing edit page.

    To Fix: Go through all of your listings and make sure each one has the proper map locations set.

    Note: If the zoom buttons don’t work then you may have javascript errors on the page.

    If you’re still having issues then I’d recommend posting the URL for peeps to help assess.

    Also, I believe the default Long/Lat cords settings only apply to the “My Location” link on the map search box (click it and see).

    This reply was awarded the best answer by the topic poster.


    Mickaël
    Newbie
     
    4 points

    Hello James,

    You write ” It calculates them then provides a “central” view of them all “.

    And instead to have this central point by default, is it possible to have the ” My location point ” by default?
    This location point define in ” theme setup / content setup / GEO Location & Google Maps / Default Map Cords

    Thank you for your help


    JamesD
    JamesD
    Elite Member
     
    448 points

    Hello Mickaël,

    I don’t know, sorry. It looks like a custom solution may be needed.

    I originally though those settings would do as you thought as well.
    Other than being used for the “my location” link I’m not sure where these settings are used.


    Brian
    Brian
    Senior Member
     
    119 points

    Make sure you have created a GOOGLE MAPS API code!! very important and set with correct permissions.

    Add at least two three Business listings to your Directory theme to test and make sure that you have the Google Maps codes correctly inserted into the backend of the theme.

    If you need any help PM me. I have a few websites running Google Maps all ok


Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.