Email assignment to send reply to website visitor not logged in


  • Mark
    Newbie
     
    3 points

    Hi All,

    Please can somebody help.

    I’m wanting to be able to send a reply to a message from a non member enquiry.

    The initial message sends fine to the member who owns the listing however when that member replies it’s not going to the email address of the person who sent the message in the first place.

    I’m guessing I’ve not set the email assignment up correctly.

    Any guidance would be much appreciated.

    Thanks.


    Josh
    Josh
    Super Guru
     
    12,955 points

    Hello Mark,
    By default you cannot reply to messages sent by non-members.You will need edit/customize theme core files to change this.Please post here >> http://www.premiumpress.com/designwork/



    Mark
    Newbie
     
    3 points

    Hi Josh,

    thanks for the reply.

    If that’s the case how can you disable the send private message option for non-members as it’s confusing at the moment. Would like to warn that you need to be logged in / registered or display message to say must be logged in before sending or even disable the message

    Please advise.

    Thanks for your help in advance.


    Josh
    Josh
    Super Guru
     
    12,955 points

    Hello Mark,
    1.Go to Theme Setup >Page Setup >Listing Page >Turn On ‘Enable Custom Display’ >Click ‘Get Code from Default Section’ (Page will refresh and some codes will appear)
    2.Locate the shortcode [CONTACT] or [CONTACTBAR].Enclose that shortcode in the shortcode [membership].
    More info: http://www.premiumpress.com/docs/#MEMBERSHIP
    For Example:
    [MEMBERSHIP show=1,2,3] [CONTACTBAR] [/MEMBERSHIP].The numbers (1,2,3) represent the Membership Package ID which you can view under Listing Setup >Membership Packages.So in my code above only members falling under the Membership Package with ID as 1 or 2 or 3 will view the contact button
    You can then add a text somewhere in same section (Page Setup >Listing Page ) notifying users they must be logged in to contact listing author



    Mark
    Newbie
     
    3 points

    Hi there,

    Thanks for the update.

    I can’t seem to turn the [CONTACTBAR] off at all!

    I’ve tried removing it completely but as long as the {CT_IMAGEBLOCK] is present the message button remains.

    Also I’m not using Memberships so only need to turn the Send Private Message bar off if not logged in.

    Thanks for your help.

    Mark.


Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.